summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-05-23 21:31:13 +0200
committerMarek Szuba <marecki@gentoo.org>2023-05-23 21:39:37 +0200
commit5de8f1446a4675e65ad2c364c87f434e861befb6 (patch)
treeb983bf147d862d0bf4613bc12e6e2eaecfeaf500 /dev-libs/isa-l_crypto
parentmail-mta/proton-mail-bridge: add 3.1.3, drop 2.3.0 (diff)
downloadgentoo-5de8f1446a4675e65ad2c364c87f434e861befb6.tar.gz
gentoo-5de8f1446a4675e65ad2c364c87f434e861befb6.tar.bz2
gentoo-5de8f1446a4675e65ad2c364c87f434e861befb6.zip
dev-libs/isa-l_crypto: new package, add 2.24.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-libs/isa-l_crypto')
-rw-r--r--dev-libs/isa-l_crypto/Manifest1
-rw-r--r--dev-libs/isa-l_crypto/files/isa-l_crypto-2.24.0_makefile-no-D.patch13
-rw-r--r--dev-libs/isa-l_crypto/isa-l_crypto-2.24.0.ebuild43
-rw-r--r--dev-libs/isa-l_crypto/metadata.xml21
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-libs/isa-l_crypto/Manifest b/dev-libs/isa-l_crypto/Manifest
new file mode 100644
index 000000000000..4934b64eadcb
--- /dev/null
+++ b/dev-libs/isa-l_crypto/Manifest
@@ -0,0 +1 @@
+DIST isa-l_crypto-2.24.0.tar.gz 687392 BLAKE2B 10b5e820f9e9d25f0f013d4cfe832760363bf1f1f2759a94f733b25ebd62b52a98262969e24be1ba86d132ee6eaefc9e64c99cceb4f9ba206c848b9aeb45f9d8 SHA512 f72800a8ff9c0b2bfdd88cb6780db91bfd5763af04a6318aa3acaff0b1326e3348cb3a4aff17c99636eb291d1ff6249dcf896392a2450adacd83ddbf4c7299da
diff --git a/dev-libs/isa-l_crypto/files/isa-l_crypto-2.24.0_makefile-no-D.patch b/dev-libs/isa-l_crypto/files/isa-l_crypto-2.24.0_makefile-no-D.patch
new file mode 100644
index 000000000000..dec1420e4d31
--- /dev/null
+++ b/dev-libs/isa-l_crypto/files/isa-l_crypto-2.24.0_makefile-no-D.patch
@@ -0,0 +1,13 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -136,8 +136,8 @@
+ EXTRA_DIST += tools/yasm-filter.sh tools/nasm-filter.sh
+ EXTRA_DIST += tools/yasm-cet-filter.sh tools/nasm-cet-filter.sh
+
+-AM_CFLAGS = ${my_CFLAGS} ${INCLUDE} $(src_include) ${D}
+-AM_CCASFLAGS = ${yasm_args} ${INCLUDE} $(src_include) ${DEFS} ${D}
++AM_CFLAGS = ${my_CFLAGS} ${INCLUDE} $(src_include) ${DIST_D}
++AM_CCASFLAGS = ${yasm_args} ${INCLUDE} $(src_include) ${DEFS} ${DIST_D}
+
+ .asm.s:
+ @echo " MKTMP " $@;
diff --git a/dev-libs/isa-l_crypto/isa-l_crypto-2.24.0.ebuild b/dev-libs/isa-l_crypto/isa-l_crypto-2.24.0.ebuild
new file mode 100644
index 000000000000..5ea355130d4b
--- /dev/null
+++ b/dev-libs/isa-l_crypto/isa-l_crypto-2.24.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Intelligent Storage Acceleration Library - cryptographic components"
+HOMEPAGE="https://github.com/intel/isa-l_crypto"
+SRC_URI="https://github.com/intel/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_avx512f"
+
+# AVX512 support in yasm is still work in progress
+BDEPEND="amd64? (
+ cpu_flags_x86_avx512f? ( >=dev-lang/nasm-2.13 )
+ !cpu_flags_x86_avx512f? ( || (
+ >=dev-lang/nasm-2.11.01
+ >=dev-lang/yasm-1.2.0
+ ) )
+)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.24.0_makefile-no-D.patch
+)
+
+src_prepare() {
+ default
+
+ # isa-l does not support arbitrary assemblers on amd64 (and presumably x86),
+ # it must be either nasm or yasm.
+ use amd64 && unset AS
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/isa-l_crypto/metadata.xml b/dev-libs/isa-l_crypto/metadata.xml
new file mode 100644
index 000000000000..aed47168584f
--- /dev/null
+++ b/dev-libs/isa-l_crypto/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription>
+ ISA-L_crypto is a collection of optimized low-level functions targeting storage applications. ISA-L_crypto includes:
+ * Multi-buffer hashes - run multiple hash jobs together on one core for much better throughput than single-buffer versions.
+ * SHA1, SHA256, SHA512, MD5, SM3
+ * Multi-hash - Get the performance of multi-buffer hashing with a single-buffer interface.
+ * Multi-hash + murmur - run both together.
+ * AES - block ciphers
+ * XTS, GCM, CBC
+ * Rolling hash - Hash input in a window which moves through the input
+ </longdescription>
+ <upstream>
+ <remote-id type="github">intel/isa-l_crypto</remote-id>
+ </upstream>
+</pkgmetadata>