summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-27 03:33:46 +0000
committerSam James <sam@gentoo.org>2021-01-27 03:33:46 +0000
commit18c8b7cf907cf5fb555cfa3126387b687277e6f7 (patch)
tree9c35c34c6b8ddf70c74efcd208c23c35e2984f95 /dev-libs/cvector
parentprofiles/features/prefix: mask more PAM consumers (diff)
downloadgentoo-18c8b7cf907cf5fb555cfa3126387b687277e6f7.tar.gz
gentoo-18c8b7cf907cf5fb555cfa3126387b687277e6f7.tar.bz2
gentoo-18c8b7cf907cf5fb555cfa3126387b687277e6f7.zip
dev-libs/cvector: port to EAPI 7
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/cvector')
-rw-r--r--dev-libs/cvector/cvector-1.0.3.1.ebuild24
-rw-r--r--dev-libs/cvector/files/1.0.3-dynlib.patch2
-rw-r--r--dev-libs/cvector/files/cvector-1.0.3.1-LDFLAGS.patch4
3 files changed, 13 insertions, 17 deletions
diff --git a/dev-libs/cvector/cvector-1.0.3.1.ebuild b/dev-libs/cvector/cvector-1.0.3.1.ebuild
index 83e0ee6f0d48..4b7b0bc8f3ab 100644
--- a/dev-libs/cvector/cvector-1.0.3.1.ebuild
+++ b/dev-libs/cvector/cvector-1.0.3.1.ebuild
@@ -1,42 +1,40 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit base eutils toolchain-funcs versionator
+inherit toolchain-funcs
MY_PN=CVector
MY_P="${MY_PN}-${PV}"
DESCRIPTION="An ANSI C implementation of dynamic arrays (approximation of C++ vectors)"
HOMEPAGE="http://cvector.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}/${MY_PN}-$(get_version_component_range 1-3)/${MY_P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${MY_PN}-$(ver_cut 1-3)/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-S="${WORKDIR}"/${MY_P}
PATCHES=(
"${FILESDIR}"/${P}-LDFLAGS.patch
"${FILESDIR}"/1.0.3-dynlib.patch
- )
+)
src_compile() {
emake \
- CC=$(tc-getCC) \
- CXX=$(tc-getCXX) \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
CFLAGS="${CFLAGS}" \
all
}
src_install() {
- ln -sf libCVector.so.$(get_version_component_range 1-3) libCVector.so.$(get_major_version) || die
- ln -sf libCVector.so.$(get_version_component_range 1-3) libCVector.so || die
- dolib.so libCVector.so*
+ ln -sf libCVector.so.$(ver_cut 1-3) libCVector.so.$(ver_cut 1) || die
+ ln -sf libCVector.so.$(ver_cut 1-3) libCVector.so || die
+ dolib.so libCVector.so*
doheader *.h
dodoc README_CVector.txt
diff --git a/dev-libs/cvector/files/1.0.3-dynlib.patch b/dev-libs/cvector/files/1.0.3-dynlib.patch
index 219f258136ed..072453e3067e 100644
--- a/dev-libs/cvector/files/1.0.3-dynlib.patch
+++ b/dev-libs/cvector/files/1.0.3-dynlib.patch
@@ -1,5 +1,3 @@
-diff --git a/Makefile b/Makefile
-index 865db81..2691108 100644
--- a/Makefile
+++ b/Makefile
@@ -96,8 +96,8 @@ BUILD_COMMAND_STATIC = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) -static -I $(IN
diff --git a/dev-libs/cvector/files/cvector-1.0.3.1-LDFLAGS.patch b/dev-libs/cvector/files/cvector-1.0.3.1-LDFLAGS.patch
index 8bed3ab01546..3bbc65f40789 100644
--- a/dev-libs/cvector/files/cvector-1.0.3.1-LDFLAGS.patch
+++ b/dev-libs/cvector/files/cvector-1.0.3.1-LDFLAGS.patch
@@ -1,5 +1,5 @@
---- Makefile 2009-07-08 04:02:56.000000000 +0200
-+++ Makefile.new 2009-07-25 11:59:27.000000000 +0200
+--- a/Makefile
++++ b/Makefile
@@ -89,10 +89,10 @@
endif