summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-23 13:45:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-23 17:18:50 +0200
commit75b75c9a2b2e7427a3d098960922bfd160bacdd3 (patch)
tree7881f46bff4e1c299e17bc8cc8c79cbc5a65c56d /dev-libs/console_bridge
parentdev-ros/ament_cmake_include_directories: Remove old (diff)
downloadgentoo-75b75c9a2b2e7427a3d098960922bfd160bacdd3.tar.gz
gentoo-75b75c9a2b2e7427a3d098960922bfd160bacdd3.tar.bz2
gentoo-75b75c9a2b2e7427a3d098960922bfd160bacdd3.zip
dev-libs/console_bridge: bump to 1.0.1
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-libs/console_bridge')
-rw-r--r--dev-libs/console_bridge/Manifest1
-rw-r--r--dev-libs/console_bridge/console_bridge-1.0.1.ebuild29
-rw-r--r--dev-libs/console_bridge/console_bridge-9999.ebuild6
3 files changed, 33 insertions, 3 deletions
diff --git a/dev-libs/console_bridge/Manifest b/dev-libs/console_bridge/Manifest
index 4ef5fa049aeb..4c658ac06b19 100644
--- a/dev-libs/console_bridge/Manifest
+++ b/dev-libs/console_bridge/Manifest
@@ -1,2 +1,3 @@
DIST console_bridge-0.4.3.tar.gz 254021 BLAKE2B dc0816c65fb44151c88935058abc1528b1162d5fa8a940956f386031a23eb087e2653954ec60ff08f2f99fc6b3da76b08d8d6db6903955061cc6832d9e2e80ef SHA512 034f69dcfe0c56b93a5bc60095afaaaa275955ff58f0ddee1a0a325eff3981c41703c8b521b43cdca5f6317d6a5775e7caf221cf2d79b5d62045b0f4315cc577
DIST console_bridge-0.4.4.tar.gz 254030 BLAKE2B ed25742be7eabe4723beb49db33c14eec8653234e86b10aaad49f0138dd610d1901be65306bd5dc1c3e297c2fff591a20dfce7f6e3134144ffc5e3e966c3c206 SHA512 9b8f165e3c2ea4a6c9ee5f551c78229aa57196d19c87a4393e9257bb65aed4dcfa0eb97a0b8c433347c71330659ca80ac6a3952775adb20312c51c31ef905184
+DIST console_bridge-1.0.1.tar.gz 259480 BLAKE2B 78df3aeaba2e7589166709e7c43a77ac021d22d0db8d379f320455a9d532b247083ff86c3e03d7f9842943c3c98f78cfb33d7920a2987433f822a05ccaf23866 SHA512 913b7ee1d5401c6324eaaab1f8a54d5ff6df4eedb119a1cd00712f223750d69313047344aec5887920497c7b456cf6cb88e5f756bfbbb5ed8223ec758cdfd021
diff --git a/dev-libs/console_bridge/console_bridge-1.0.1.ebuild b/dev-libs/console_bridge/console_bridge-1.0.1.ebuild
new file mode 100644
index 000000000000..82bb72cef12a
--- /dev/null
+++ b/dev-libs/console_bridge/console_bridge-1.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros/console_bridge"
+fi
+
+inherit ${SCM} cmake multilib
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm"
+ SRC_URI="https://github.com/ros/console_bridge/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="A ROS-independent package for logging into rosconsole/rosout"
+HOMEPAGE="http://wiki.ros.org/console_bridge"
+LICENSE="BSD"
+SLOT="0/1"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=[threads]"
+DEPEND="${RDEPEND}"
diff --git a/dev-libs/console_bridge/console_bridge-9999.ebuild b/dev-libs/console_bridge/console_bridge-9999.ebuild
index 1fac726c6456..82bb72cef12a 100644
--- a/dev-libs/console_bridge/console_bridge-9999.ebuild
+++ b/dev-libs/console_bridge/console_bridge-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,7 +9,7 @@ if [ "${PV#9999}" != "${PV}" ] ; then
EGIT_REPO_URI="https://github.com/ros/console_bridge"
fi
-inherit ${SCM} cmake-utils multilib
+inherit ${SCM} cmake multilib
if [ "${PV#9999}" != "${PV}" ] ; then
KEYWORDS=""
@@ -22,7 +22,7 @@ fi
DESCRIPTION="A ROS-independent package for logging into rosconsole/rosout"
HOMEPAGE="http://wiki.ros.org/console_bridge"
LICENSE="BSD"
-SLOT="0/4"
+SLOT="0/1"
IUSE=""
RDEPEND="dev-libs/boost:=[threads]"