summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/boost-numpy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/boost-numpy')
-rw-r--r--dev-libs/boost-numpy/Manifest1
-rw-r--r--dev-libs/boost-numpy/boost-numpy-0_pre20131206.ebuild34
-rw-r--r--dev-libs/boost-numpy/boost-numpy-9999.ebuild34
-rw-r--r--dev-libs/boost-numpy/metadata.xml13
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-libs/boost-numpy/Manifest b/dev-libs/boost-numpy/Manifest
new file mode 100644
index 000000000000..48dadf84720a
--- /dev/null
+++ b/dev-libs/boost-numpy/Manifest
@@ -0,0 +1 @@
+DIST boost-numpy-0_pre20131206.tar.xz 53136 SHA256 113a7f71c2f62d009ba8329f05e07a76061e4f1b2392ff68a62998f7c52d62a0 SHA512 323084f58252d51c3dbbbcd49a427cd4c1adb4a9bcb68efb4c5d1b252d1baa3f66f2b7b24a7ed71c5ae0a7ebbfcf5af8033ad562206bc781f12588fb080a0448 WHIRLPOOL 5f6a8443280b2a0b325f14428ed8b7c0b7a976c2ff58adff3427c72deb8abc44c0988020ab9007f24f72c399a531ca6176f3639fa1d446bc3e137e97bf9667c6
diff --git a/dev-libs/boost-numpy/boost-numpy-0_pre20131206.ebuild b/dev-libs/boost-numpy/boost-numpy-0_pre20131206.ebuild
new file mode 100644
index 000000000000..f8eabec23bbd
--- /dev/null
+++ b/dev-libs/boost-numpy/boost-numpy-0_pre20131206.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Boost.Python interface for NumPy"
+HOMEPAGE="https://github.com/ndarray/Boost.NumPy"
+if [ ${PV} == 9999 ]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/ndarray/Boost.NumPy.git \
+ https://github.com/ndarray/Boost.NumPy.git"
+else
+ SRC_URI="http://dev.gentoo.org/~heroxbd/${P}.tar.xz"
+fi
+
+LICENSE="Boost-1.0"
+SLOT=0
+IUSE="doc examples"
+KEYWORDS="~amd64"
+
+CDEPEND="dev-python/numpy
+ dev-libs/boost[python]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+src_install() {
+ cmake-utils_src_install
+
+ use doc && dodoc -r libs/numpy/doc/*
+ use examples && dodoc -r libs/numpy/example
+}
diff --git a/dev-libs/boost-numpy/boost-numpy-9999.ebuild b/dev-libs/boost-numpy/boost-numpy-9999.ebuild
new file mode 100644
index 000000000000..b3e60b390972
--- /dev/null
+++ b/dev-libs/boost-numpy/boost-numpy-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Boost.Python interface for NumPy"
+HOMEPAGE="https://github.com/ndarray/Boost.NumPy"
+if [ ${PV} == 9999 ]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/ndarray/Boost.NumPy.git \
+ https://github.com/ndarray/Boost.NumPy.git"
+else
+ SRC_URI="http://dev.gentoo.org/~heroxbd/${P}.tar.xz"
+fi
+
+LICENSE="Boost-1.0"
+SLOT=0
+IUSE="doc examples"
+KEYWORDS=""
+
+CDEPEND="dev-python/numpy
+ dev-libs/boost[python]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+src_install() {
+ cmake-utils_src_install
+
+ use doc && dodoc -r libs/numpy/doc/*
+ use examples && dodoc -r libs/numpy/example
+}
diff --git a/dev-libs/boost-numpy/metadata.xml b/dev-libs/boost-numpy/metadata.xml
new file mode 100644
index 000000000000..116fc61c5972
--- /dev/null
+++ b/dev-libs/boost-numpy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>heroxbd@gentoo.org</email>
+ <name>Benda Xu</name>
+ <description>an extension for Boost.Python that adds NumPy support</description>
+ </maintainer>
+ <longdescription>It is intended as a replacement for the old numeric support in Boost.Python proper, which is now out-of-date and does not support C/C++ pointer access to the data.</longdescription>
+ <upstream>
+ <remote-id type="github">ndarray/Boost.NumPy</remote-id>
+ </upstream>
+</pkgmetadata>