summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-05-25 12:31:41 -0400
committerMike Gilbert <floppym@gentoo.org>2024-05-25 12:31:41 -0400
commit09632c98c8bd1f6755ca10d8955ec7519d26a964 (patch)
treec09ea82089fffa0bf100424a15721889c0f9297c /dev-libs/atf
parentnet-analyzer/zabbix: dropped obsolete 6.0.28 & 6.4.13 (diff)
downloadgentoo-09632c98c8bd1f6755ca10d8955ec7519d26a964.tar.gz
gentoo-09632c98c8bd1f6755ca10d8955ec7519d26a964.tar.bz2
gentoo-09632c98c8bd1f6755ca10d8955ec7519d26a964.zip
dev-libs/atf: fix build with libcxx
Closes: https://bugs.gentoo.org/932716 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-libs/atf')
-rw-r--r--dev-libs/atf/atf-0.21-r2.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-libs/atf/atf-0.21-r2.ebuild b/dev-libs/atf/atf-0.21-r2.ebuild
index 52b664460cb5..eb7e4c723eae 100644
--- a/dev-libs/atf/atf-0.21-r2.ebuild
+++ b/dev-libs/atf/atf-0.21-r2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit flag-o-matic
+
DESCRIPTION="Libraries to write tests in C, C++ and shell"
HOMEPAGE="https://github.com/jmmv/atf"
SRC_URI="https://github.com/jmmv/atf/releases/download/${P}/${P}.tar.gz"
@@ -16,6 +18,13 @@ BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}"/${P}-getopt-solaris.patch )
+src_configure() {
+ # Uses std::auto_ptr (deprecated in c++11, removed in c++17)
+ append-cxxflags "-std=c++14"
+
+ default
+}
+
src_install() {
default
rm -r "${ED}"/usr/tests || die