summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-05-07 13:22:24 -0400
committerMike Gilbert <floppym@gentoo.org>2022-05-07 14:32:45 -0400
commit90cf216685b854b1cce976b9167da4995bf65e77 (patch)
treeef7c4f7cf528d3d909beb2244edcb7858daa6dad /dev-lang
parentsys-apps/baobab: Keyword 42.0 ppc, #838709 (diff)
downloadgentoo-90cf216685b854b1cce976b9167da4995bf65e77.tar.gz
gentoo-90cf216685b854b1cce976b9167da4995bf65e77.tar.bz2
gentoo-90cf216685b854b1cce976b9167da4995bf65e77.zip
dev-lang/python: set QA_PKGCONFIG_VERSION
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-2.7.18_p15.ebuild2
-rw-r--r--dev-lang/python/python-3.10.4.ebuild2
-rw-r--r--dev-lang/python/python-3.11.0_alpha7.ebuild2
-rw-r--r--dev-lang/python/python-3.7.13.ebuild2
-rw-r--r--dev-lang/python/python-3.8.13.ebuild2
-rw-r--r--dev-lang/python/python-3.9.12.ebuild2
6 files changed, 12 insertions, 0 deletions
diff --git a/dev-lang/python/python-2.7.18_p15.ebuild b/dev-lang/python/python-2.7.18_p15.ebuild
index da93a624d8f9..b156a86e951e 100644
--- a/dev-lang/python/python-2.7.18_p15.ebuild
+++ b/dev-lang/python/python-2.7.18_p15.ebuild
@@ -65,6 +65,8 @@ RDEPEND+="
VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/python.org.asc
+QA_PKGCONFIG_VERSION=${PYVER}
+
pkg_setup() {
if use berkdb; then
ewarn "'bsddb' module is out-of-date and no longer maintained inside"
diff --git a/dev-lang/python/python-3.10.4.ebuild b/dev-lang/python/python-3.10.4.ebuild
index dc3f7d5f5153..598af7c9b101 100644
--- a/dev-lang/python/python-3.10.4.ebuild
+++ b/dev-lang/python/python-3.10.4.ebuild
@@ -83,6 +83,8 @@ VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/python.org.asc
# large file tests involve a 2.5G file being copied (duplicated)
CHECKREQS_DISK_BUILD=5500M
+QA_PKGCONFIG_VERSION=${PYVER}
+
pkg_pretend() {
use test && check-reqs_pkg_pretend
}
diff --git a/dev-lang/python/python-3.11.0_alpha7.ebuild b/dev-lang/python/python-3.11.0_alpha7.ebuild
index ee3604d253a3..e0a70414581f 100644
--- a/dev-lang/python/python-3.11.0_alpha7.ebuild
+++ b/dev-lang/python/python-3.11.0_alpha7.ebuild
@@ -75,6 +75,8 @@ VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/python.org.asc
# large file tests involve a 2.5G file being copied (duplicated)
CHECKREQS_DISK_BUILD=5500M
+QA_PKGCONFIG_VERSION=${PYVER}
+
pkg_pretend() {
use test && check-reqs_pkg_pretend
}
diff --git a/dev-lang/python/python-3.7.13.ebuild b/dev-lang/python/python-3.7.13.ebuild
index 7e2a80660c9e..20483909387c 100644
--- a/dev-lang/python/python-3.7.13.ebuild
+++ b/dev-lang/python/python-3.7.13.ebuild
@@ -71,6 +71,8 @@ RDEPEND+="
VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/python.org.asc
+QA_PKGCONFIG_VERSION=${PYVER}
+
src_unpack() {
if use verify-sig; then
verify-sig_verify_detached "${DISTDIR}"/${MY_P}.tar.xz{,.asc}
diff --git a/dev-lang/python/python-3.8.13.ebuild b/dev-lang/python/python-3.8.13.ebuild
index 90f86c62042e..d6afe442a0f7 100644
--- a/dev-lang/python/python-3.8.13.ebuild
+++ b/dev-lang/python/python-3.8.13.ebuild
@@ -74,6 +74,8 @@ RDEPEND+="
VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/python.org.asc
+QA_PKGCONFIG_VERSION=${PYVER}
+
src_unpack() {
if use verify-sig; then
verify-sig_verify_detached "${DISTDIR}"/${MY_P}.tar.xz{,.asc}
diff --git a/dev-lang/python/python-3.9.12.ebuild b/dev-lang/python/python-3.9.12.ebuild
index ad323554ca2d..110efb768a04 100644
--- a/dev-lang/python/python-3.9.12.ebuild
+++ b/dev-lang/python/python-3.9.12.ebuild
@@ -78,6 +78,8 @@ VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/python.org.asc
# large file tests involve a 2.5G file being copied (duplicated)
CHECKREQS_DISK_BUILD=5500M
+QA_PKGCONFIG_VERSION=${PYVER}
+
pkg_pretend() {
use test && check-reqs_pkg_pretend
}