summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-04-23 15:42:31 -0700
committerPatrick McLean <chutzpah@gentoo.org>2024-04-23 15:43:26 -0700
commit2f7bd5c6a198ff4dae8ebd3d8c5c97d898f9b9ef (patch)
tree474f828eee3c18dbe6c9c309c49081bfa6063b7a /dev-lang
parentnet-libs/libupnp: add 1.14.19 (diff)
downloadgentoo-2f7bd5c6a198ff4dae8ebd3d8c5c97d898f9b9ef.tar.gz
gentoo-2f7bd5c6a198ff4dae8ebd3d8c5c97d898f9b9ef.tar.bz2
gentoo-2f7bd5c6a198ff4dae8ebd3d8c5c97d898f9b9ef.zip
dev-lang/jsonnet: enable py3.12
Closes: https://bugs.gentoo.org/929401 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/jsonnet/jsonnet-0.20.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-lang/jsonnet/jsonnet-0.20.0.ebuild b/dev-lang/jsonnet/jsonnet-0.20.0.ebuild
index 8e5c294e6207..ddfb40c0dfd7 100644
--- a/dev-lang/jsonnet/jsonnet-0.20.0.ebuild
+++ b/dev-lang/jsonnet/jsonnet-0.20.0.ebuild
@@ -1,22 +1,24 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_OPTIONAL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( pypy3 python3_{9..12} )
inherit cmake toolchain-funcs flag-o-matic distutils-r1
DESCRIPTION="A data templating language for app and tool developers"
HOMEPAGE="https://jsonnet.org/"
SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-IUSE="custom-optimization doc examples python test"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="custom-optimization doc examples python test"
+
RDEPEND="
dev-cpp/rapidyaml:=
dev-cpp/nlohmann_json:=