summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-06 17:09:57 +0100
committerSam James <sam@gentoo.org>2022-10-06 17:10:39 +0100
commit07da00e100b4c9ea0c6c5c790ce0c7d20aa1118f (patch)
treed7a1665a725b8880f6c4905a5f512eb2b45bb3ba /dev-lang/rust
parentmedia-tv/kodi: Fix IndirectInherits warning (diff)
downloadgentoo-07da00e100b4c9ea0c6c5c790ce0c7d20aa1118f.tar.gz
gentoo-07da00e100b4c9ea0c6c5c790ce0c7d20aa1118f.tar.bz2
gentoo-07da00e100b4c9ea0c6c5c790ce0c7d20aa1118f.zip
dev-lang/rust: fix has_version default-libcxx test for Clang
We moved the flag to sys-devel/clang-common to prepare for proper config file support (which is backported to 15.0.2, although it's going to be better in 16.x). Go for the hack for now, but keep the bug open as we want to switch to the proper link test from the LLVM ebuilds. Bug: https://bugs.gentoo.org/875563 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/rust-1.62.1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.63.0-r1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.64.0-r1.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/rust/rust-1.62.1.ebuild b/dev-lang/rust/rust-1.62.1.ebuild
index fd5d2a9b6277..b951a931e407 100644
--- a/dev-lang/rust/rust-1.62.1.ebuild
+++ b/dev-lang/rust/rust-1.62.1.ebuild
@@ -310,7 +310,7 @@ src_configure() {
# https://bugs.gentoo.org/732632
if tc-is-clang; then
local clang_slot="$(clang-major-version)"
- if { has_version "sys-devel/clang:${clang_slot}[default-libcxx]" || is-flagq -stdlib=libc++; }; then
+ if { has_version "sys-devel/clang:${clang_slot}[default-libcxx(-)]" || has_version "sys-devel/clang-common:${clang_slot}[default-libcxx(-)]" || is-flagq -stdlib=libc++; }; then
use_libcxx="true"
fi
fi
diff --git a/dev-lang/rust/rust-1.63.0-r1.ebuild b/dev-lang/rust/rust-1.63.0-r1.ebuild
index b8cb10204eef..8f553b1aaac0 100644
--- a/dev-lang/rust/rust-1.63.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.63.0-r1.ebuild
@@ -340,7 +340,7 @@ src_configure() {
# https://bugs.gentoo.org/732632
if tc-is-clang; then
local clang_slot="$(clang-major-version)"
- if { has_version "sys-devel/clang:${clang_slot}[default-libcxx]" || is-flagq -stdlib=libc++; }; then
+ if { has_version "sys-devel/clang:${clang_slot}[default-libcxx(-)]" || has_version "sys-devel/clang-common:${clang_slot}[default-libcxx(-)]" || is-flagq -stdlib=libc++; }; then
use_libcxx="true"
fi
fi
diff --git a/dev-lang/rust/rust-1.64.0-r1.ebuild b/dev-lang/rust/rust-1.64.0-r1.ebuild
index 92c592d49b21..436894d9af83 100644
--- a/dev-lang/rust/rust-1.64.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.64.0-r1.ebuild
@@ -338,7 +338,7 @@ src_configure() {
# https://bugs.gentoo.org/732632
if tc-is-clang; then
local clang_slot="$(clang-major-version)"
- if { has_version "sys-devel/clang:${clang_slot}[default-libcxx]" || is-flagq -stdlib=libc++; }; then
+ if { has_version "sys-devel/clang:${clang_slot}[default-libcxx(-)]" || has_version "sys-devel/clang-common:${clang_slot}[default-libcxx(-)]" || is-flagq -stdlib=libc++; }; then
use_libcxx="true"
fi
fi