summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2020-12-07 21:32:24 -0500
committerBrian Evans <grknight@gentoo.org>2020-12-07 21:32:24 -0500
commit8c791c3e47ecf2ad892b2585ae732ad49965ee70 (patch)
tree02071f3a47b6e4dc8093fcfe03a8bb94c77efa90 /dev-lang/php
parentapp-eselect/eselect-php: Version bump for 0.9.7 (diff)
downloadgentoo-8c791c3e47ecf2ad892b2585ae732ad49965ee70.tar.gz
gentoo-8c791c3e47ecf2ad892b2585ae732ad49965ee70.tar.bz2
gentoo-8c791c3e47ecf2ad892b2585ae732ad49965ee70.zip
dev-lang/php: Fix embed and apache2 installs for 8.0.0
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/php-8.0.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/php/php-8.0.0.ebuild b/dev-lang/php/php-8.0.0.ebuild
index 59f2e692f17c..801d79b66ceb 100644
--- a/dev-lang/php/php-8.0.0.ebuild
+++ b/dev-lang/php/php-8.0.0.ebuild
@@ -75,7 +75,7 @@ RESTRICT="!test? ( test )"
# the ./configure script. Other versions *work*, but we need to stick to
# the ones that can be detected to avoid a repeat of bug #564824.
COMMON_DEPEND="
- >=app-eselect/eselect-php-0.9.1[apache2?,fpm?]
+ >=app-eselect/eselect-php-0.9.7[apache2?,fpm?]
>=dev-libs/libpcre2-10.30[unicode]
fpm? ( acl? ( sys-apps/acl ) )
apache2? ( www-servers/apache[apache2_modules_unixd(+),threads=] )
@@ -538,7 +538,7 @@ src_install() {
# We're specifically not using emake install-sapi as libtool
# may cause unnecessary relink failures (see bug #351266)
insinto "${PHP_DESTDIR#${EPREFIX}}/apache2/"
- newins ".libs/libphp${PHP_MV}$(get_libname)" \
+ newins ".libs/libphp$(get_libname)" \
"libphp${PHP_MV}$(get_libname)"
keepdir "/usr/$(get_libdir)/apache2/modules"
else
@@ -561,7 +561,7 @@ src_install() {
source="sapi/fpm/php-fpm"
;;
embed)
- source="libs/libphp${PHP_MV}$(get_libname)"
+ source="libs/libphp$(get_libname)"
;;
phpdbg)
source="sapi/phpdbg/phpdbg"