summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-12-20 23:11:03 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-12-20 23:11:44 +0100
commit7b878520dc290dfc30177193882ac622ad99c799 (patch)
treeee45f5738581ec0abcbec58395daaadd3997d305 /dev-lang/php
parentnet-irc/hexchat: migrate to lua-single.eclass (diff)
downloadgentoo-7b878520dc290dfc30177193882ac622ad99c799.tar.gz
gentoo-7b878520dc290dfc30177193882ac622ad99c799.tar.bz2
gentoo-7b878520dc290dfc30177193882ac622ad99c799.zip
dev-lang/php: allow building against >=dev-lilbs/icu-68.1
Upstream's official solution is to restore previous ICU behavior using -DU_DEFINE_FALSE_AND_TRUE=1 [Link 1]. But this patch alone is not enough for PHP 7.2. However, PHP 7.2 has reached EOL so we will do same like upstream but via global {C,CXX}FLAGS. Link 1: https://github.com/php/php-src/commit/8eaaabdd58a395853d3658418622ee24635cb871 Closes: https://bugs.gentoo.org/759352 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/php-7.2.34.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-lang/php/php-7.2.34.ebuild b/dev-lang/php/php-7.2.34.ebuild
index 07f0645b8d80..b7fe1520efba 100644
--- a/dev-lang/php/php-7.2.34.ebuild
+++ b/dev-lang/php/php-7.2.34.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-inherit flag-o-matic systemd autotools
+inherit flag-o-matic systemd autotools toolchain-funcs
DESCRIPTION="The PHP language runtime engine"
HOMEPAGE="https://www.php.net/"
@@ -239,6 +239,10 @@ src_configure() {
addpredict /usr/share/snmp/mibs/.index #nowarn
addpredict /var/lib/net-snmp/mib_indexes #nowarn
+ # Fix building against >=ICU-68, https://bugs.php.net/80310
+ append-cflags -DU_DEFINE_FALSE_AND_TRUE=1
+ append-cxxflags -DU_DEFINE_FALSE_AND_TRUE=1
+
PHP_DESTDIR="${EPREFIX}/usr/$(get_libdir)/php${SLOT}"
# The php-fpm config file wants localstatedir to be ${EPREFIX}/var