summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-30 01:14:54 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-30 01:27:34 +0100
commitbf1e389a2632e668c3ffdcd8092609aab6b72e9b (patch)
treed724eb42ba51615d6f18c55d73f356fe7cb489d7 /dev-lang/oorexx/oorexx-5.0.0.ebuild
parentsys-kernel/linux-firmware: drop 20231111-r1 (diff)
downloadgentoo-bf1e389a2632e668c3ffdcd8092609aab6b72e9b.tar.gz
gentoo-bf1e389a2632e668c3ffdcd8092609aab6b72e9b.tar.bz2
gentoo-bf1e389a2632e668c3ffdcd8092609aab6b72e9b.zip
dev-lang/oorexx: new package; add 5.0.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/oorexx/oorexx-5.0.0.ebuild')
-rw-r--r--dev-lang/oorexx/oorexx-5.0.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-lang/oorexx/oorexx-5.0.0.ebuild b/dev-lang/oorexx/oorexx-5.0.0.ebuild
new file mode 100644
index 000000000000..51c81bc9f4f2
--- /dev/null
+++ b/dev-lang/oorexx/oorexx-5.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+APP_REVISION=12583
+
+inherit cmake
+
+DESCRIPTION="Open source implementation of Object Rexx"
+HOMEPAGE="https://www.oorexx.org/about.html
+ https://sourceforge.net/projects/oorexx/"
+SRC_URI="https://sourceforge.net/projects/${PN}/files/${PN}/${PV}/${P}-${APP_REVISION}.tar.gz"
+S="${WORKDIR}/${P}"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ virtual/libcrypt:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-5.0.0-man.patch" )
+
+src_unpack() {
+ default
+
+ # HACK: Dance around cmake.eclass S directory requirements.
+ mv "${WORKDIR}" "${T}/${P}" || die
+ mkdir -p "${WORKDIR}" || die
+ mv "${T}/${P}" "${S}" || die
+}