summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-13 21:20:19 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-14 20:23:32 +0100
commit2f9c42cb12b476a78214e2f7d5bb3f984ce05de6 (patch)
treea090b49934af522bd3f29135d3c4f7bbfeb9c5dd /dev-lang/julia
parentMove {dev-util → dev-build}/tinycmmc (diff)
downloadgentoo-2f9c42cb12b476a78214e2f7d5bb3f984ce05de6.tar.gz
gentoo-2f9c42cb12b476a78214e2f7d5bb3f984ce05de6.tar.bz2
gentoo-2f9c42cb12b476a78214e2f7d5bb3f984ce05de6.zip
Move {dev-util → dev-build}/cmake
Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/34792 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/julia')
-rw-r--r--dev-lang/julia/julia-1.8.3-r4.ebuild4
-rw-r--r--dev-lang/julia/julia-1.8.5-r1.ebuild6
-rw-r--r--dev-lang/julia/julia-1.9.0.ebuild6
-rw-r--r--dev-lang/julia/julia-1.9.4.ebuild6
4 files changed, 11 insertions, 11 deletions
diff --git a/dev-lang/julia/julia-1.8.3-r4.ebuild b/dev-lang/julia/julia-1.8.3-r4.ebuild
index a7496a13dbbd..c21a564cc460 100644
--- a/dev-lang/julia/julia-1.8.3-r4.ebuild
+++ b/dev-lang/julia/julia-1.8.3-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# correct versions for stdlibs are in deps/checksums
@@ -48,7 +48,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
BDEPEND="
- dev-util/cmake
+ dev-build/cmake
virtual/pkgconfig
"
diff --git a/dev-lang/julia/julia-1.8.5-r1.ebuild b/dev-lang/julia/julia-1.8.5-r1.ebuild
index fbe4522110f4..c38278524dae 100644
--- a/dev-lang/julia/julia-1.8.5-r1.ebuild
+++ b/dev-lang/julia/julia-1.8.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# correct versions for stdlibs are in deps/checksums
@@ -9,7 +9,7 @@ EAPI=8
# >=1.8.2 still sits on LLVM 13, bug: https://bugs.gentoo.org/876184
MY_LLVM_V=13.0.1
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit check-reqs flag-o-matic optfeature pax-utils python-any-r1 toolchain-funcs
@@ -59,7 +59,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
${PYTHON_DEPS}
- dev-util/cmake
+ dev-build/cmake
virtual/pkgconfig
"
diff --git a/dev-lang/julia/julia-1.9.0.ebuild b/dev-lang/julia/julia-1.9.0.ebuild
index 302f4215540c..6dfef422bd55 100644
--- a/dev-lang/julia/julia-1.9.0.ebuild
+++ b/dev-lang/julia/julia-1.9.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# correct versions for stdlibs are in deps/checksums
@@ -8,7 +8,7 @@ EAPI=8
MY_LLVM_V=14.0.6
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit check-reqs flag-o-matic optfeature pax-utils python-any-r1 toolchain-funcs
@@ -55,7 +55,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
${PYTHON_DEPS}
- dev-util/cmake
+ dev-build/cmake
virtual/pkgconfig
"
diff --git a/dev-lang/julia/julia-1.9.4.ebuild b/dev-lang/julia/julia-1.9.4.ebuild
index b0105c0e508f..82e0fb7987d9 100644
--- a/dev-lang/julia/julia-1.9.4.ebuild
+++ b/dev-lang/julia/julia-1.9.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# correct versions for stdlibs are in deps/checksums
@@ -8,7 +8,7 @@ EAPI=8
MY_LLVM_V=14.0.6
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit check-reqs flag-o-matic optfeature pax-utils python-any-r1 toolchain-funcs
@@ -54,7 +54,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
${PYTHON_DEPS}
- dev-util/cmake
+ dev-build/cmake
virtual/pkgconfig
"