summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-04 07:39:57 +0000
committerSam James <sam@gentoo.org>2024-03-04 07:40:03 +0000
commitfe8b20a48349bbd32c170e1e15fb573ab7909680 (patch)
tree60d6b4206f1de539ec42ddeffa8d5394299780ac /dev-java
parentapp-accessibility/flite: fix build w/ make-4.4 (diff)
downloadgentoo-fe8b20a48349bbd32c170e1e15fb573ab7909680.tar.gz
gentoo-fe8b20a48349bbd32c170e1e15fb573ab7909680.tar.bz2
gentoo-fe8b20a48349bbd32c170e1e15fb573ab7909680.zip
dev-java/icedtea: fix build w/ make-4.4
Closes: https://bugs.gentoo.org/882611 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icedtea/files/openjdk-8-make-4.4.patch13
-rw-r--r--dev-java/icedtea/icedtea-3.21.0.ebuild2
2 files changed, 15 insertions, 0 deletions
diff --git a/dev-java/icedtea/files/openjdk-8-make-4.4.patch b/dev-java/icedtea/files/openjdk-8-make-4.4.patch
new file mode 100644
index 000000000000..1217895b7547
--- /dev/null
+++ b/dev-java/icedtea/files/openjdk-8-make-4.4.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/882611
+https://build.opensuse.org/package/view_file/openSUSE:Factory/java-1_8_0-openjdk/make-jobserver-detection.patch?expand=1
+--- openjdk/make/MakeHelpers.gmk
++++ openjdk/make/MakeHelpers.gmk
+@@ -145,7 +145,7 @@ endef
+
+ # Hook to be called as the very first thing when running a normal build
+ define AtMakeStart
+- $(if $(findstring --jobserver,$(MAKEFLAGS)),$(error make -j is not supported, use make JOBS=n))
++ $(if $(findstring jobserver,$(.FEATURES)),,$(error make -j is not supported, use make JOBS=n))
+ $(call CheckEnvironment)
+ @$(PRINTF) $(LOG_INFO) "Running make as '$(MAKE) $(MFLAGS) $(MAKE_ARGS)'\n"
+ @$(PRINTF) "Building $(PRODUCT_NAME) for target '$(call GetRealTarget)' in configuration '$(CONF_NAME)'\n\n"
diff --git a/dev-java/icedtea/icedtea-3.21.0.ebuild b/dev-java/icedtea/icedtea-3.21.0.ebuild
index 2cfc8e518512..c4fd8dd748b4 100644
--- a/dev-java/icedtea/icedtea-3.21.0.ebuild
+++ b/dev-java/icedtea/icedtea-3.21.0.ebuild
@@ -203,7 +203,9 @@ src_configure() {
# ${FILESDIR} directly.
mkdir -v gentoo_patches || die
cp -v "${FILESDIR}/openjdk-8-hotspot-arrayallocator.patch" gentoo_patches || die
+ cp -v "${FILESDIR}/openjdk-8-make-4.4.patch" gentoo_patches || die
export DISTRIBUTION_PATCHES="gentoo_patches//openjdk-8-hotspot-arrayallocator.patch"
+ DISTRIBUTION_PATCHES+=" gentoo_patches//openjdk-8-make-4.4.patch"
# For bootstrap builds as the sandbox control file might not yet exist.
addpredict /proc/self/coredump_filter #nowarn