summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/offo-hyphenation
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/offo-hyphenation')
-rw-r--r--dev-java/offo-hyphenation/Manifest1
-rw-r--r--dev-java/offo-hyphenation/metadata.xml8
-rw-r--r--dev-java/offo-hyphenation/offo-hyphenation-1.2.ebuild40
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-java/offo-hyphenation/Manifest b/dev-java/offo-hyphenation/Manifest
new file mode 100644
index 000000000000..07c0ef95e269
--- /dev/null
+++ b/dev-java/offo-hyphenation/Manifest
@@ -0,0 +1 @@
+DIST offo-hyphenation_v1.2.zip 378809 SHA256 026c3605416e921cdc5b24ba486fef306d1a4863ba95295f689b7190885e5c5a SHA512 ef0cb0aa7020bedd6c59f6d4cec95274f18fc5a7d19d24d1a05014c7c20b70c8e515aa7b7db4852a0c1bb87f594f638a906b5b61c0443804902cc9876d35d934 WHIRLPOOL 1a644a55a1769a866fa47e654310b942ef176396c3c2070c7b69f3e5e82e69156f42535363a127733753488bcddfee5b41b505ba512b4a0126f37fec96b6c98a
diff --git a/dev-java/offo-hyphenation/metadata.xml b/dev-java/offo-hyphenation/metadata.xml
new file mode 100644
index 000000000000..12697493b88a
--- /dev/null
+++ b/dev-java/offo-hyphenation/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">offo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-java/offo-hyphenation/offo-hyphenation-1.2.ebuild b/dev-java/offo-hyphenation/offo-hyphenation-1.2.ebuild
new file mode 100644
index 000000000000..e9fd44928849
--- /dev/null
+++ b/dev-java/offo-hyphenation/offo-hyphenation-1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Hyphenation patterns for Apache Fop"
+HOMEPAGE="http://offo.sourceforge.net"
+# upstream will hopefully version future release...
+SRC_URI="mirror://sourceforge/offo/${PN}_v${PV}.zip"
+# review this upon update!
+LICENSE="GPL-2 Apache-2.0 LPPL-1.3b TeX"
+SLOT="0"
+KEYWORDS=" amd64 ppc ppc64 x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/${PN}/
+ insinto /usr/share/${PN}/
+ doins -r hyph
+
+ dohtml licenses.html || die
+ if use doc; then
+ dohtml -r images skin i*.html
+ fi
+}
+
+pkg_postinst() {
+ elog "This package installs hyphenation files for several languages"
+ elog "into /usr/share/${PN}/hyph"
+ elog "Check /usr/share/doc/${PF}/html/licenses.html for each file's license."
+ elog "To compile the patterns, install dev-java/fop with USE=hyphenation."
+ elog "Alternatively, use the uncompiled patterns via the <hyphenation-base>"
+ elog "configuration option. See the documentation for more details."
+}