summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-jexl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-jexl')
-rw-r--r--dev-java/commons-jexl/Manifest2
-rw-r--r--dev-java/commons-jexl/commons-jexl-1.1.ebuild52
-rw-r--r--dev-java/commons-jexl/commons-jexl-2.1.1.ebuild57
-rw-r--r--dev-java/commons-jexl/files/1.1-test-target.patch12
-rw-r--r--dev-java/commons-jexl/files/2.1.1-build.xml127
-rw-r--r--dev-java/commons-jexl/metadata.xml5
6 files changed, 255 insertions, 0 deletions
diff --git a/dev-java/commons-jexl/Manifest b/dev-java/commons-jexl/Manifest
new file mode 100644
index 000000000000..17e7e980b74f
--- /dev/null
+++ b/dev-java/commons-jexl/Manifest
@@ -0,0 +1,2 @@
+DIST commons-jexl-1.1-src.tar.gz 128030 SHA256 62026d0cb3edecaadfdee1cf3dfe70a27b7f7ae70a219d7cb7c0f37db57877d5 SHA512 d403e945060385c4546cf173af9ec4a795c074a9b56aacdf16f301b875c9f78b47a91fdfb84059805a082466d8a4a371bcb6ef6336e6ba806272ad8e2cce9e13 WHIRLPOOL e2ed6bac38718a0daab839d5bfd22ed33bf4c701fcdf3632fee294b6ff479b661b5d179d5119944035485213e035962e06149767f0426c3ac99db8869d5fa325
+DIST commons-jexl-2.1.1-src.tar.gz 208559 SHA256 5f06cfec88f0ce1bc51958e9ec1410af7029f2a5eb2e0b167d5d71bec43027aa SHA512 259c0956bb10f102cb3d860b1c99d3d2b2bc5d705e4160f743fa774640ed8c1ee6f3aad518a8a69e8f94a164b21cb2ae26e47cd3e81e92a086a3c3f753befacb WHIRLPOOL d4a7a56cd7b5aeb0d568b3c23b763268a651da9b2fcb76c6188469dd617993a5939f4ab0ea91efd6df2f3ad9daafdddcff046693a4ecfe5585ce95abe68ed6e4
diff --git a/dev-java/commons-jexl/commons-jexl-1.1.ebuild b/dev-java/commons-jexl/commons-jexl-1.1.ebuild
new file mode 100644
index 000000000000..8f01544149cb
--- /dev/null
+++ b/dev-java/commons-jexl/commons-jexl-1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Expression language engine, can be embedded in applications and frameworks"
+HOMEPAGE="http://commons.apache.org/jexl/"
+SRC_URI="mirror://apache/jakarta/commons/jexl/source/${P}-src.tar.gz"
+
+CDEPEND="dev-java/commons-logging
+ =dev-java/junit-3*"
+
+RDEPEND=">=virtual/jre-1.4
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/ant-junit )
+ ${CDEPEND}"
+
+LICENSE="Apache-2.0"
+SLOT="1.0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+S="${WORKDIR}/${P}-src"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # https://issues.apache.org/jira/browse/JEXL-31
+ epatch "${FILESDIR}/1.1-test-target.patch"
+
+ mkdir -p target/lib && cd target/lib
+ java-pkg_jar-from junit junit.jar
+ java-pkg_jar-from commons-logging
+}
+
+src_test() {
+ ANT_TASKS="ant-junit" eant test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}*.jar
+
+ dodoc RELEASE-NOTES.txt || die
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc "${S}"/src/java/*
+}
diff --git a/dev-java/commons-jexl/commons-jexl-2.1.1.ebuild b/dev-java/commons-jexl/commons-jexl-2.1.1.ebuild
new file mode 100644
index 000000000000..b38d155d2ab1
--- /dev/null
+++ b/dev-java/commons-jexl/commons-jexl-2.1.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Expression language engine, can be embedded in applications and frameworks"
+HOMEPAGE="http://commons.apache.org/jexl/"
+SRC_URI="mirror://apache/commons/jexl/source/${P}-src.tar.gz"
+
+CDEPEND="dev-java/commons-logging:0"
+
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.5
+ >=dev-java/javacc-5
+ test? ( dev-java/ant-junit:0 )
+ ${CDEPEND}"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="commons-logging"
+
+java_prepare() {
+ cp "${FILESDIR}"/${PV}-build.xml build.xml || die
+
+ # these two calls is what the "jjtree-javacc" goal in the pom.xml does
+ jjtree -OUTPUT_DIRECTORY="${S}/src/main/java/org/apache/commons/jexl2/parser/" \
+ src/main/java/org/apache/commons/jexl2/parser/Parser.jjt \
+ || die "Code generation via jjtree failed"
+ javacc -OUTPUT_DIRECTORY="${S}/src/main/java/org/apache/commons/jexl2/parser/" \
+ src/main/java/org/apache/commons/jexl2/parser/Parser.jj \
+ || die "Parser.java code generation via javacc failed"
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ dodoc RELEASE-NOTES.txt NOTICE.txt
+
+ use doc && java-pkg_dojavadoc "${S}"/target/site/apidocs
+ use source && java-pkg_dosrc "${S}"/src/main/java/*
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
diff --git a/dev-java/commons-jexl/files/1.1-test-target.patch b/dev-java/commons-jexl/files/1.1-test-target.patch
new file mode 100644
index 000000000000..54a3d3e9bce0
--- /dev/null
+++ b/dev-java/commons-jexl/files/1.1-test-target.patch
@@ -0,0 +1,12 @@
+diff -ur commons-jexl-1.1-src.old/build.xml commons-jexl-1.1-src/build.xml
+--- commons-jexl-1.1-src.old/build.xml 2006-12-26 19:39:18.000000000 +0200
++++ commons-jexl-1.1-src/build.xml 2006-12-26 19:39:34.000000000 +0200
+@@ -62,7 +62,7 @@
+ </fileset>
+ </copy>
+ </target>
+- <target name="jar" description="o Create the jar" depends="compile,test">
++ <target name="jar" description="o Create the jar" depends="compile">
+ <jar jarfile="${defaulttargetdir}/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}" manifest="src/conf/MANIFEST.MF">
+ </jar>
+ </target>
diff --git a/dev-java/commons-jexl/files/2.1.1-build.xml b/dev-java/commons-jexl/files/2.1.1-build.xml
new file mode 100644
index 000000000000..d0bf54ef3571
--- /dev/null
+++ b/dev-java/commons-jexl/files/2.1.1-build.xml
@@ -0,0 +1,127 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<project name="commons-jexl-from-maven" default="package" basedir=".">
+ <property file="${user.home}/.m2/maven.properties" />
+ <property file="maven-build.properties" />
+
+ <property name="maven.build.finalName" value="commons-jexl" />
+ <property name="maven.build.dir" value="target" />
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes" />
+ <property name="maven.build.srcDir.0" value="src/main/java" />
+ <property name="maven.build.resourceDir.0" value="src/main/resources" />
+ <property name="maven.build.resourceDir.1" value="." />
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes" />
+ <property name="maven.build.testDir.0" value="src/test/java" />
+ <property name="maven.build.testResourceDir.0" value="src/test/resources" />
+ <property name="maven.build.testResourceDir.1" value="." />
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports" />
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site" />
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository" />
+ <property name="maven.settings.offline" value="false" />
+ <property name="maven.settings.interactiveMode" value="true" />
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath" />
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}" />
+ </target>
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}" />
+ <javac destdir="${maven.build.outputDir}" encoding="iso-8859-1" nowarn="false" debug="true" optimize="false" deprecation="true" target="1.5" verbose="false" fork="false" source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}" />
+ </src>
+ <classpath refid="build.classpath" />
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}" />
+ </copy>
+ <mkdir dir="${maven.build.outputDir}/META-INF" />
+ </target>
+
+ <target name="compile-tests" depends="compile" description="Compile the test code" unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}" />
+ <javac destdir="${maven.build.testOutputDir}" encoding="iso-8859-1" nowarn="false" debug="true" optimize="false" deprecation="true" target="1.5" verbose="false" fork="false" source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}" />
+ </src>
+ <classpath>
+ <path refid="build.test.classpath" />
+ <pathelement location="${maven.build.outputDir}" />
+ </classpath>
+ </javac>
+ <mkdir dir="${maven.build.testOutputDir}/META-INF" />
+ </target>
+
+ <target name="test" depends="compile-tests, junit-missing" unless="junit.skipped" description="Run the test cases">
+ <mkdir dir="${maven.test.reports}" />
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="." />
+ <formatter type="xml" />
+ <formatter type="plain" usefile="false" />
+ <classpath>
+ <path refid="build.test.classpath" />
+ <pathelement location="${maven.build.outputDir}" />
+ <pathelement location="${maven.build.testOutputDir}" />
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/*Test.java" />
+ <exclude name="**/*Abstract*Test.java" />
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java" />
+ <exclude name="**/*Abstract*Test.java" />
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present" />
+ </target>
+
+ <target name="test-junit-status" depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}" />
+ <isfalse value="${maven.test.skip}" />
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}" />
+ <istrue value="${maven.test.skip}" />
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing" depends="test-junit-status" if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}" packagenames="*" destdir="${maven.reporting.outputDirectory}/apidocs" access="protected" old="false" verbose="false" encoding="iso-8859-1" version="true" use="true" author="true" splitindex="false" nodeprecated="false" nodeprecatedlist="false" notree="false" noindex="false" nohelp="false" nonavbar="false" serialwarn="false" charset="ISO-8859-1" source="1.5" linksource="true" breakiterator="false">
+ </javadoc>
+ </target>
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar" compress="true" index="false" basedir="${maven.build.outputDir}" excludes="**/package.html">
+ </jar>
+ </target>
+
+ <target name="jar" depends="package" description="Builds the jar for the application" />
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true" />
+ </condition>
+ </target>
+</project>
diff --git a/dev-java/commons-jexl/metadata.xml b/dev-java/commons-jexl/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/commons-jexl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>