summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2022-07-23 22:01:07 +1000
committerMark Wright <gienah@gentoo.org>2022-07-23 22:03:21 +1000
commit342aee5ad39bcf0e180d04f0350f4d21920cb2be (patch)
treea55daf218e7bea9a88b8f15367643f1f403b4d4a /dev-haskell/yaml
parentdev-haskell/cabal-install: Loosen HTTP dep (diff)
downloadgentoo-342aee5ad39bcf0e180d04f0350f4d21920cb2be.tar.gz
gentoo-342aee5ad39bcf0e180d04f0350f4d21920cb2be.tar.bz2
gentoo-342aee5ad39bcf0e180d04f0350f4d21920cb2be.zip
dev-haskell/yaml: Bump to 0.11.8.0
Closes: https://bugs.gentoo.org/860234 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-haskell/yaml')
-rw-r--r--dev-haskell/yaml/Manifest2
-rw-r--r--dev-haskell/yaml/metadata.xml6
-rw-r--r--dev-haskell/yaml/yaml-0.11.8.0.ebuild (renamed from dev-haskell/yaml/yaml-0.11.5.0.ebuild)34
3 files changed, 27 insertions, 15 deletions
diff --git a/dev-haskell/yaml/Manifest b/dev-haskell/yaml/Manifest
index 5fa0fd4d46b2..b578e00692e0 100644
--- a/dev-haskell/yaml/Manifest
+++ b/dev-haskell/yaml/Manifest
@@ -1 +1 @@
-DIST yaml-0.11.5.0.tar.gz 30049 BLAKE2B 96e7d8b39ac392ac927a61991a2c645dd564e36a7676984193e447ad591bddedb9029136aa6f71c65a0665a05516f907a0151b85d7e7f22169d7d5ddc98e6c5d SHA512 a4209cdbe75413191aed5a72f13a0cc4af04906a3e8ce629711689624f334b31681dcfc2fc89fdae20a874c5e6831e9663a30188d34d8067491ff8958912930b
+DIST yaml-0.11.8.0.tar.gz 31674 BLAKE2B a4c508eecb4e5b931e6832ceee0bd694fc6879cc6c3482a48e44c1b865207e3525c52cd51a9e2ec74a9ef98e1537f8d559151da80c0ef07351ace1665e5b5f09 SHA512 f47ae0a158bfd323e06ff31db348f916077882f4198b160c7f3f88e89ae0e62a9f17ff5ba29c15a1d74a52d040245613eced5267c38f9658d0a19007efb402f7
diff --git a/dev-haskell/yaml/metadata.xml b/dev-haskell/yaml/metadata.xml
index 2eae49bd2eae..3d126b223c2e 100644
--- a/dev-haskell/yaml/metadata.xml
+++ b/dev-haskell/yaml/metadata.xml
@@ -7,14 +7,14 @@
</maintainer>
<longdescription>
Provides support for parsing and emitting Yaml documents.
-
+
This package includes the full libyaml C library version 0.1.12 by Kirill
Simonov (&lt;http://pyyaml.org/wiki/LibYAML&gt;) in the package so you
don't need to worry about any non-Haskell dependencies.
</longdescription>
<use>
- <flag name="no-examples">don't build the examples</flag>
- <flag name="no-exe">don't install the yaml2json executable</flag>
+ <flag name="examples">Install the haskell-yaml-examples executable</flag>
+ <flag name="executable">Install the yaml2json and json2yaml executables</flag>
</use>
<upstream>
<remote-id type="github">snoyberg/yaml</remote-id>
diff --git a/dev-haskell/yaml/yaml-0.11.5.0.ebuild b/dev-haskell/yaml/yaml-0.11.8.0.ebuild
index ec7829b83f61..a1a113a969b2 100644
--- a/dev-haskell/yaml/yaml-0.11.5.0.ebuild
+++ b/dev-haskell/yaml/yaml-0.11.8.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-# ebuild generated by hackport 0.6.6.9999
+# ebuild generated by hackport 0.7.1.1.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
@@ -15,33 +15,45 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="+no-examples +no-exe"
+IUSE="examples executable"
RDEPEND=">=dev-haskell/aeson-0.11:=[profile?]
>=dev-haskell/attoparsec-0.11.3.0:=[profile?]
>=dev-haskell/conduit-1.2.8:=[profile?] <dev-haskell/conduit-1.4:=[profile?]
>=dev-haskell/libyaml-0.1:=[profile?] <dev-haskell/libyaml-0.2:=[profile?]
- dev-haskell/mtl:=[profile?]
>=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-1.3:=[profile?]
>=dev-haskell/scientific-0.3:=[profile?]
- dev-haskell/text:=[profile?]
dev-haskell/unordered-containers:=[profile?]
dev-haskell/vector:=[profile?]
- >=dev-lang/ghc-8.0.2:=
- !no-examples? ( dev-haskell/raw-strings-qq:=[profile?] )
+ >=dev-lang/ghc-8.4.3:=
+ examples? ( dev-haskell/raw-strings-qq:=[profile?] )
+ executable? ( dev-haskell/optparse-applicative:=[profile?] )
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.24.2.0
+ >=dev-haskell/cabal-2.2.0.1
test? ( dev-haskell/base-compat
>=dev-haskell/hspec-1.3
dev-haskell/hunit
dev-haskell/mockery
dev-haskell/temporary
- no-examples? ( dev-haskell/raw-strings-qq ) )
+ !examples? ( dev-haskell/raw-strings-qq ) )
"
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'executable examples' 'executable haskell-yaml-examples'
+}
+
src_configure() {
+ local examples_flag="no-examples"
+ use examples && examples_flag="-no-examples"
+
+ local exe_flag="no-exe"
+ use executable && exe_flag="-no-exe"
+
haskell-cabal_src_configure \
- $(cabal_flag no-examples no-examples) \
- $(cabal_flag no-exe no-exe)
+ --flag="${examples_flag}" \
+ --flag="${exe_flag}"
}