summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-08-21 23:24:03 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-08-21 23:31:32 +0200
commit4dad8cbccfbe592823d44dd30b45b0d60671341b (patch)
treecaf6840b3b781b1cfd04903d855668b39185046f /dev-haskell/uniqueid
parentdev-haskell/unixutils: treeclean (diff)
downloadgentoo-4dad8cbccfbe592823d44dd30b45b0d60671341b.tar.gz
gentoo-4dad8cbccfbe592823d44dd30b45b0d60671341b.tar.bz2
gentoo-4dad8cbccfbe592823d44dd30b45b0d60671341b.zip
dev-haskell/uniqueid: treeclean
Closes: https://bugs.gentoo.org/815238 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-haskell/uniqueid')
-rw-r--r--dev-haskell/uniqueid/Manifest1
-rw-r--r--dev-haskell/uniqueid/files/uniqueid-0.1.1-ghc-7.8.patch46
-rw-r--r--dev-haskell/uniqueid/metadata.xml18
-rw-r--r--dev-haskell/uniqueid/uniqueid-0.1.1.ebuild24
4 files changed, 0 insertions, 89 deletions
diff --git a/dev-haskell/uniqueid/Manifest b/dev-haskell/uniqueid/Manifest
deleted file mode 100644
index a2b1a2b03278..000000000000
--- a/dev-haskell/uniqueid/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST uniqueid-0.1.1.tar.gz 2779 BLAKE2B 73ad9af177f20575caaefb12261d58801a391bfcbaa6b8ef1596538fd7536ec8b6aa35997277a39454250bc779c4c6174b1b3e7853bad5cc21d9ed72764ce517 SHA512 4a1f753a320a5ddae8dd47c3e3729144cf28effaaa6f16a8cf13ad614e4aba3f720f82025f86d7c04ae5c28d03825b4d3442caa01cd534dfa05a70c6c9cadc68
diff --git a/dev-haskell/uniqueid/files/uniqueid-0.1.1-ghc-7.8.patch b/dev-haskell/uniqueid/files/uniqueid-0.1.1-ghc-7.8.patch
deleted file mode 100644
index a48815ecda0e..000000000000
--- a/dev-haskell/uniqueid/files/uniqueid-0.1.1-ghc-7.8.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff --git a/Data/Unique/Id.hs b/Data/Unique/Id.hs
-index f41127e..56853d9 100644
---- a/Data/Unique/Id.hs
-+++ b/Data/Unique/Id.hs
-@@ -14,7 +14,7 @@ module Data.Unique.Id (
- ) where
-
- import GHC.Exts
--import GHC.IOBase ( unsafeDupableInterleaveIO )
-+import GHC.IO ( unsafeDupableInterleaveIO )
-
- import Data.IORef
- import System.IO.Unsafe ( unsafePerformIO )
-@@ -55,15 +55,15 @@ splitIdSupplyL ids = ids1 : splitIdSupplyL ids2
- idFromSupply :: IdSupply -> Id
- idFromSupply (IdSupply n _ _) = Id (I# n)
-
--instance Eq Id where Id (I# x) == Id (I# y) = x ==# y
-+instance Eq Id where Id (I# x) == Id (I# y) = isTrue# (x ==# y)
-
- instance Ord Id
- where
-- Id (I# x) < Id (I# y) = x <# y
-- Id (I# x) <= Id (I# y) = x <=# y
-+ Id (I# x) < Id (I# y) = isTrue# (x <# y)
-+ Id (I# x) <= Id (I# y) = isTrue# (x <=# y)
-
- compare (Id (I# x)) (Id (I# y)) =
-- if x ==# y then EQ else if x <# y then LT else GT
-+ if isTrue# (x ==# y) then EQ else if isTrue# (x <# y) then LT else GT
-
- instance Show Id
- where
-diff --git a/uniqueid.cabal b/uniqueid.cabal
-index 8099520..83aaa39 100644
---- a/uniqueid.cabal
-+++ b/uniqueid.cabal
-@@ -18,7 +18,7 @@ Build-Type: Simple
- Stability: experimental
-
- Library
-- Build-Depends: base >= 3 && < 5
-+ Build-Depends: base >= 3 && < 5, ghc-prim
- Exposed-Modules: Data.Unique.Id
- Extensions: MagicHash
- Ghc-Options: -Wall
diff --git a/dev-haskell/uniqueid/metadata.xml b/dev-haskell/uniqueid/metadata.xml
deleted file mode 100644
index 5e894ac2443c..000000000000
--- a/dev-haskell/uniqueid/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- This package provides splittable supplies of unique
- identifiers. The implementation mimics (only) essential
- parts of the code that is used internally in GHC for
- the same purpose. After improvements of the value-supply
- package it is now deprecated.
- </longdescription>
- <upstream>
- <remote-id type="github">sebfisch/uniqueid</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-haskell/uniqueid/uniqueid-0.1.1.ebuild b/dev-haskell/uniqueid/uniqueid-0.1.1.ebuild
deleted file mode 100644
index e229c4991267..000000000000
--- a/dev-haskell/uniqueid/uniqueid-0.1.1.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.3.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Splittable Unique Identifier Supply"
-HOMEPAGE="https://github.com/sebfisch/uniqueid/wikis"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-lang/ghc-7.8.1:="
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6"
-
-PATCHES=("${FILESDIR}"/${P}-ghc-7.8.patch)