summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-10-21 21:37:32 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-10-21 22:20:32 -0400
commitcbc343591d3efc77a714e71275d7c72181720cb5 (patch)
tree0f2c14c3f3c5c91a0ff10dc3044778ce68ec2eb5 /dev-games/clanlib
parentdev-games/clanlib: stabilize 0.8.1-r2 for amd64, x86 (diff)
downloadgentoo-cbc343591d3efc77a714e71275d7c72181720cb5.tar.gz
gentoo-cbc343591d3efc77a714e71275d7c72181720cb5.tar.bz2
gentoo-cbc343591d3efc77a714e71275d7c72181720cb5.zip
dev-games/clanlib: fix :2.3 build on x86 with USE=opengl
This likely been broken in stable for a long time, perhaps since the switch to libglvnd (assuming it was tested and ever worked). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-games/clanlib')
-rw-r--r--dev-games/clanlib/clanlib-2.3.7-r2.ebuild1
-rw-r--r--dev-games/clanlib/files/clanlib-2.3.7-32bit-opengl.patch19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-games/clanlib/clanlib-2.3.7-r2.ebuild b/dev-games/clanlib/clanlib-2.3.7-r2.ebuild
index b27100b9778d..5a2389c1c055 100644
--- a/dev-games/clanlib/clanlib-2.3.7-r2.ebuild
+++ b/dev-games/clanlib/clanlib-2.3.7-r2.ebuild
@@ -52,6 +52,7 @@ PATCHES=(
"${FILESDIR}"/${P}-doc.patch
"${FILESDIR}"/${P}-freetype_pkgconfig.patch #764902
"${FILESDIR}"/${P}-glibc2.34.patch
+ "${FILESDIR}"/${P}-32bit-opengl.patch
)
DOCS=( CODING_STYLE CREDITS PATCHES README )
diff --git a/dev-games/clanlib/files/clanlib-2.3.7-32bit-opengl.patch b/dev-games/clanlib/files/clanlib-2.3.7-32bit-opengl.patch
new file mode 100644
index 000000000000..73d5287c5dd9
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-2.3.7-32bit-opengl.patch
@@ -0,0 +1,19 @@
+Patch taken from Fedora, removes redefinitions that conflicts on x86.
+--- a/Sources/API/GL/opengl_defines.h
++++ b/Sources/API/GL/opengl_defines.h
+@@ -69,6 +69,4 @@
+ typedef void GLvoid;
+ typedef char GLchar;
+-typedef ptrdiff_t GLintptr;
+-typedef ptrdiff_t GLsizeiptr;
+ typedef struct __CLsync *CLsync;
+
+--- a/Sources/API/GL1/opengl1_defines.h
++++ b/Sources/API/GL1/opengl1_defines.h
+@@ -65,6 +65,4 @@
+ typedef void GLvoid;
+ typedef char GLchar;
+-typedef ptrdiff_t GLintptr;
+-typedef ptrdiff_t GLsizeiptr;
+
+ #else