summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-09-03 11:48:44 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-09-03 11:50:45 +0300
commit683bc1afeaa098aad5b5f9351dbc6beb7662fb3b (patch)
tree72f0175b29dbee0f4826204d2bbadb0a0c49a739 /dev-embedded
parentwww-servers/apache: move patches from ebuild to tarball (diff)
downloadgentoo-683bc1afeaa098aad5b5f9351dbc6beb7662fb3b.tar.gz
gentoo-683bc1afeaa098aad5b5f9351dbc6beb7662fb3b.tar.bz2
gentoo-683bc1afeaa098aad5b5f9351dbc6beb7662fb3b.zip
dev-embedded/avarice: fix implicit function declarations in configure logs
Patch configure.ac for clang 16. Update EAPI 7 -> 8. Closes: https://bugs.gentoo.org/900687 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/avarice/avarice-2.14-r1.ebuild36
-rw-r--r--dev-embedded/avarice/files/avarice-2.14-implicit-function-declarations.patch24
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-embedded/avarice/avarice-2.14-r1.ebuild b/dev-embedded/avarice/avarice-2.14-r1.ebuild
new file mode 100644
index 000000000000..43beb06d967d
--- /dev/null
+++ b/dev-embedded/avarice/avarice-2.14-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Interface for GDB to Atmel AVR JTAGICE in circuit emulator"
+HOMEPAGE="https://avarice.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-broken-__unused-macro.patch
+ "${FILESDIR}"/${P}-implicit-function-declarations.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # bug #788295
+ append-cxxflags -std=c++14
+
+ default
+}
+
+src_install() {
+ default
+ dodoc doc/*.txt
+}
diff --git a/dev-embedded/avarice/files/avarice-2.14-implicit-function-declarations.patch b/dev-embedded/avarice/files/avarice-2.14-implicit-function-declarations.patch
new file mode 100644
index 000000000000..1d266b0bb113
--- /dev/null
+++ b/dev-embedded/avarice/files/avarice-2.14-implicit-function-declarations.patch
@@ -0,0 +1,24 @@
+Bug: https://bugs.gentoo.org/900687
+Upstream patch: https://sourceforge.net/p/avarice/patches/41/
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -97,7 +97,7 @@
+
+ # Checks for header files.
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h sys/time.h termios.h unistd.h])
++AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h sys/stat.h sys/time.h termios.h unistd.h])
+
+ AC_CHECK_HEADERS([bfd.h], , [ac_found_bfd_h=no])
+
+@@ -142,6 +142,9 @@
+ AC_MSG_CHECKING([whether libbfd requires libdl])
+ AC_LINK_IFELSE(
+ [AC_LANG_SOURCE([#include <bfd.h>
++ #ifndef bfd_get_section_name
++ extern bfd_get_section_name(bfd *abfd, const char *name);
++ #endif
+ bfd *file;
+ int main(void) {
+ bfd_init();