summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-07-30 17:15:59 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-07-30 17:23:30 -0400
commit6028d0afd2a4a8ca6bb78d6b513c5148740d5112 (patch)
treeff73b1d1c3ee89be1d9a57422d7ea3fc394e49b7 /dev-embedded
parentdev-embedded/xa: add 2.4.1 (diff)
downloadgentoo-6028d0afd2a4a8ca6bb78d6b513c5148740d5112.tar.gz
gentoo-6028d0afd2a4a8ca6bb78d6b513c5148740d5112.tar.bz2
gentoo-6028d0afd2a4a8ca6bb78d6b513c5148740d5112.zip
dev-embedded/xa: adjust patch
Re-add bug link and remove context (context is not super useful for this patch and it sometimes allows to rebase it less often, albeit in this case it added a trivial -g on the CFLAGS line). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/xa/files/xa-2.4.1-make.patch48
-rw-r--r--dev-embedded/xa/xa-2.4.1.ebuild2
2 files changed, 9 insertions, 41 deletions
diff --git a/dev-embedded/xa/files/xa-2.4.1-make.patch b/dev-embedded/xa/files/xa-2.4.1-make.patch
index da08bdb10618..c4fd2f667584 100644
--- a/dev-embedded/xa/files/xa-2.4.1-make.patch
+++ b/dev-embedded/xa/files/xa-2.4.1-make.patch
@@ -1,60 +1,28 @@
+https://bugs.gentoo.org/722600
--- a/Makefile
+++ b/Makefile
-@@ -1,12 +1,8 @@
- # Unix gcc or DOS go32 cross-compiling gcc
- #
- VERS = 2.4.1
+@@ -4,2 +3,0 @@
-CC = gcc
-LD = gcc
- # for testing. not to be used; build failures in misc/.
- #CFLAGS = -O2 -W -Wall -pedantic -ansi -g
+@@ -8,2 +5,0 @@
-CFLAGS = -O2 -g
-LDFLAGS = -lc
-
- # for DOS?
- # CC = gcc-go32
-@@ -29,19 +25,19 @@
-
- TESTS=ALL
-
+@@ -32 +28 @@
-all: killxa xa uncpk
+all: xa uncpk
-
- killxa:
- rm -f xa
-
- xa:
+@@ -38 +34 @@
- (cd src && LD=${LD} CC="${CC} ${CFLAGS}" ${MAKE})
+ (cd src && ${MAKE})
-
- #load:
- # (cd loader && CC="${CC} ${CFLAGS}" ${MAKE})
-
- uncpk:
+@@ -44 +40 @@
- (cd misc && CC="${CC} ${CFLAGS}" ${MAKE})
+ (cd misc && ${MAKE})
-
- dos: clean
- (cd src && LD=gcc-go32 CC=gcc-go32 CFLAGS="-W -Wall -pedantic" ${MAKE})
--- a/misc/Makefile
+++ b/misc/Makefile
-@@ -2,7 +2,7 @@
- XCBMLIB = ..
-
- # -Wall -ansi et al. cause compile problems.
+@@ -5 +5 @@
-CFLAGS = -O2 -g
+CFLAGS := $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
-
- LIBS = #-lncurses -ltermcap -lm
-
--- a/src/Makefile
+++ b/src/Makefile
-@@ -9,7 +9,7 @@
- all: xa
-
- xa: ${OBJ}
+@@ -12 +12 @@
- ${LD} -o ../xa ${OBJ} ${LDFLAGS}
+ ${CC} ${LDFLAGS} -o ../xa ${OBJ}
-
- clean:
- rm -f *.o *.o65
diff --git a/dev-embedded/xa/xa-2.4.1.ebuild b/dev-embedded/xa/xa-2.4.1.ebuild
index 0efb54ed1c9f..35f2dd66f1e2 100644
--- a/dev-embedded/xa/xa-2.4.1.ebuild
+++ b/dev-embedded/xa/xa-2.4.1.ebuild
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
PATCHES=(
- "${FILESDIR}"/${P}-make.patch
+ "${FILESDIR}"/${PN}-2.4.1-make.patch
)
src_configure() {