summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Gysel <me@bearsh.org>2020-02-15 23:52:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-07 13:13:46 +0200
commite2b7a6e1f367d473880f5a5466f0712eebfe4e53 (patch)
tree46201fac69942f72bc980f6f80666aeca0900fa9 /dev-embedded/ponyprog/files
parentdev-util/cppunit: drop 1.14.0 (diff)
downloadgentoo-e2b7a6e1f367d473880f5a5466f0712eebfe4e53.tar.gz
gentoo-e2b7a6e1f367d473880f5a5466f0712eebfe4e53.tar.bz2
gentoo-e2b7a6e1f367d473880f5a5466f0712eebfe4e53.zip
dev-embedded/ponyprog: 3.1.2 version bump
- switch to eapi7 and cmake.eclass - use forked qhexedit2 but as internal copy - add dep on libusb and libftdi Bug: https://bugs.gentoo.org/696626 Signed-off-by: Martin Gysel <me@bearsh.org> Closes: https://github.com/gentoo/gentoo/pull/19870 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-embedded/ponyprog/files')
-rw-r--r--dev-embedded/ponyprog/files/ponyprog-3.1.1-fix-build-system.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-embedded/ponyprog/files/ponyprog-3.1.1-fix-build-system.patch b/dev-embedded/ponyprog/files/ponyprog-3.1.1-fix-build-system.patch
new file mode 100644
index 000000000000..9f4e44d69267
--- /dev/null
+++ b/dev-embedded/ponyprog/files/ponyprog-3.1.1-fix-build-system.patch
@@ -0,0 +1,17 @@
+--- a/CMakeLists.txt.old 2020-02-15 13:35:28.308010048 +0100
++++ b/CMakeLists.txt 2020-02-15 13:37:06.726655159 +0100
+@@ -42,14 +42,6 @@
+ OPTION (USE_PROFILER "Include in binary file profiling information" OFF)
+
+
+-IF(${USE_DEBUGGER})
+- SET(CMAKE_BUILD_TYPE Debug)
+- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS_DEBUG} -Wall")
+-ELSE()
+- SET(CMAKE_BUILD_TYPE Release)
+- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS_RELEASE} -Wall")
+-ENDIF()
+-
+ MESSAGE(STATUS "CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS}")
+
+ INCLUDE(CheckIncludeFile)