summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2015-09-17 19:43:27 +0200
committerChristoph Mende <angelos@gentoo.org>2015-09-17 21:01:08 +0200
commitf1b8f00c590e6bcc97c26b7faec54042fb5c292a (patch)
treefa27e51cc3e66c6d6fd62b8bc2bfb701246ba7ca /dev-dotnet/dbus-sharp/dbus-sharp-0.8.1.ebuild
parentgtk-sharp-module.eclass: Add support for gtk-sharp-2.12.21 (diff)
downloadgentoo-f1b8f00c590e6bcc97c26b7faec54042fb5c292a.tar.gz
gentoo-f1b8f00c590e6bcc97c26b7faec54042fb5c292a.tar.bz2
gentoo-f1b8f00c590e6bcc97c26b7faec54042fb5c292a.zip
dev-dotnet/dbus-sharp: version bump to 0.8.1
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-dotnet/dbus-sharp/dbus-sharp-0.8.1.ebuild')
-rw-r--r--dev-dotnet/dbus-sharp/dbus-sharp-0.8.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-dotnet/dbus-sharp/dbus-sharp-0.8.1.ebuild b/dev-dotnet/dbus-sharp/dbus-sharp-0.8.1.ebuild
new file mode 100644
index 000000000000..9baa04c202ce
--- /dev/null
+++ b/dev-dotnet/dbus-sharp/dbus-sharp-0.8.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools mono-env eutils
+
+DESCRIPTION="D-Bus for .NET"
+HOMEPAGE="https://github.com/mono/dbus-sharp"
+SRC_URI="https://github.com/mono/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/mono
+ sys-apps/dbus"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS="AUTHORS README"
+ mono-env_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e 's/gmcs/mcs/' configure.ac || die
+ eautoreconf
+}