summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-17 20:18:07 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-17 20:18:07 +0100
commitf5d59e5be82a7901cb44dc44456c5dc79e8ec4f1 (patch)
tree8effd17590cb8eaab38c21b30ad500e51aee4f7a /dev-debug
parentsys-libs/compiler-rt: Remove old (diff)
downloadgentoo-f5d59e5be82a7901cb44dc44456c5dc79e8ec4f1.tar.gz
gentoo-f5d59e5be82a7901cb44dc44456c5dc79e8ec4f1.tar.bz2
gentoo-f5d59e5be82a7901cb44dc44456c5dc79e8ec4f1.zip
dev-debug/lldb: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/lldb/Manifest1
-rw-r--r--dev-debug/lldb/lldb-19.0.0_pre20240203.ebuild107
2 files changed, 0 insertions, 108 deletions
diff --git a/dev-debug/lldb/Manifest b/dev-debug/lldb/Manifest
index 8331df891e0b..820a3cb5dd77 100644
--- a/dev-debug/lldb/Manifest
+++ b/dev-debug/lldb/Manifest
@@ -6,5 +6,4 @@ DIST llvm-project-17.0.6.src.tar.xz 127838860 BLAKE2B d6ede1a9fda8756995c3e06541
DIST llvm-project-17.0.6.src.tar.xz.sig 438 BLAKE2B 186e75b6a0fbfe1e85408589c149e1800fcc47d685b74e4260018e05cd08bc793d1d1197c9c50e177eea941a3d0c65cb0c583ce6dae449099b920adf8a508ef7 SHA512 f78c55053a6450625f3e95f52c305110b4468a9854fec75831b65b8d6ceee3c9206ab9e63c4b5fda8be9bd344f72cfbdaae0520ed240abd505e08ebeaa25d340
DIST llvm-project-18.1.0rc2.src.tar.xz 131993176 BLAKE2B 8df1e34a54214975efe1b9a649753a2dc20c04e3c763bd8648000f48dd18f27ccfdc597ff6e68e0f408310493dfa92f48c7eee53376501e8ebc3b7c614809c15 SHA512 b595bb5d029723fee4e8f8edeaddd6fdcd48d668f66f4239e3208fd19d3a3622e8e4f90ae3fa4b1216fca1621d6c6b6ebf4d99dec7febff2457d0ceb79e8617a
DIST llvm-project-18.1.0rc2.src.tar.xz.sig 566 BLAKE2B c765549386a92883bd348d9be25a3c92b1e66a1bac71385ef99978ec2af413a7616a2d9699c57554d927f95b80a3584572557d26e3df16b2ff6678359d5fd6b0 SHA512 83bb4c133f34faec8a0109689ed7aa18222c9a803ba8c95c571a18e854726024f106a1c8e3a820020255c426b7fa8bda26789ff1546972e233fbe3e3ab3a8e91
-DIST llvm-project-78b4e7c5e349d8c101b50affbd260eb109748f8f.tar.gz 207433034 BLAKE2B ab7189fe82b5a9309348b499130295b3057dbb263ad9c60b1748e4ea92be3a85f0160baa1408dde5516650994951d9f948223d2d6260492a07b07dde51a51ff9 SHA512 366ecb02720d2b550ebeca989abf74ca1c93b2585a95fa378f44edc6c3329ee4e1548f5fa2cf7a19e59bc817abe6cc8850841415227380114c59b58867959a5a
DIST llvm-project-8884ba43a8485bebef5c4d41e7ed457e3fa84f07.tar.gz 205853916 BLAKE2B 115809efbf062ced32ffe61b25e65e44a0b3c293f68bf40fc4d9e596cd077fc4781a059ad24c4dc7a139c6ec884a6a183ebac06535f2498116266695e19daf00 SHA512 cb496111ec72163a1872fa9a14f8963108d3185f4464a74cc45d26ccc5071bc36895618b81c29063cde0564a50017a0194da4dc559a046a12550d9ab0d9b8347
diff --git a/dev-debug/lldb/lldb-19.0.0_pre20240203.ebuild b/dev-debug/lldb/lldb-19.0.0_pre20240203.ebuild
deleted file mode 100644
index 6d10771e220b..000000000000
--- a/dev-debug/lldb/lldb-19.0.0_pre20240203.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake llvm.org llvm-utils python-single-r1
-
-DESCRIPTION="The LLVM debugger"
-HOMEPAGE="https://llvm.org/"
-
-LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
-SLOT="0/${LLVM_SOABI}"
-IUSE="+debug debuginfod +libedit lzma ncurses +python test +xml"
-RESTRICT="test"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-DEPEND="
- debuginfod? (
- net-misc/curl:=
- dev-cpp/cpp-httplib:=
- )
- libedit? ( dev-libs/libedit:0= )
- lzma? ( app-arch/xz-utils:= )
- ncurses? ( >=sys-libs/ncurses-5.9-r3:0= )
- xml? ( dev-libs/libxml2:= )
- ~sys-devel/clang-${PV}
- ~sys-devel/llvm-${PV}[debuginfod=]
-"
-RDEPEND="
- ${DEPEND}
- python? (
- ${PYTHON_DEPS}
- )
-"
-BDEPEND="
- ${PYTHON_DEPS}
- python? (
- >=dev-lang/swig-3.0.11
- )
- test? (
- $(python_gen_cond_dep "
- ~dev-python/lit-${PV}[\${PYTHON_USEDEP}]
- dev-python/psutil[\${PYTHON_USEDEP}]
- ")
- sys-devel/lld
- )
-"
-
-LLVM_COMPONENTS=( lldb cmake llvm/utils )
-LLVM_TEST_COMPONENTS=( llvm/lib/Testing/Support third-party )
-llvm.org_set_globals
-
-src_configure() {
- llvm_prepend_path "${LLVM_MAJOR}"
-
- # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
- use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
-
- local mycmakeargs=(
- -DLLDB_ENABLE_CURSES=$(usex ncurses)
- -DLLDB_ENABLE_LIBEDIT=$(usex libedit)
- -DLLDB_ENABLE_PYTHON=$(usex python)
- -DLLDB_ENABLE_LUA=OFF
- -DLLDB_ENABLE_LZMA=$(usex lzma)
- -DLLDB_ENABLE_LIBXML2=$(usex xml)
- -DLLVM_ENABLE_TERMINFO=$(usex ncurses)
-
- -DLLDB_INCLUDE_TESTS=$(usex test)
-
- -DCLANG_LINK_CLANG_DYLIB=ON
- # TODO: fix upstream to detect this properly
- -DHAVE_LIBDL=ON
- -DHAVE_LIBPTHREAD=ON
-
- # normally we'd have to set LLVM_ENABLE_TERMINFO, HAVE_TERMINFO
- # and TERMINFO_LIBS... so just force FindCurses.cmake to use
- # ncurses with complete library set (including autodetection
- # of -ltinfo)
- -DCURSES_NEED_NCURSES=ON
-
- -DCLANG_RESOURCE_DIR="../../../clang/${LLVM_MAJOR}"
-
- -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
- -DPython3_EXECUTABLE="${PYTHON}"
- )
- use test && mycmakeargs+=(
- -DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="$(get_lit_flags)"
- )
-
- cmake_src_configure
-}
-
-src_test() {
- local -x LIT_PRESERVES_TMP=1
- cmake_build check-lldb-{shell,unit}
- # failures + hangs
- #use python && cmake_build check-lldb-api
-}
-
-src_install() {
- cmake_src_install
- find "${D}" -name '*.a' -delete || die
-
- use python && python_optimize
-}