summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-03 10:05:37 +0000
committerSam James <sam@gentoo.org>2024-01-03 10:06:38 +0000
commit45b8c3f13cd57daf17fe0c8d7a5752af43bcc248 (patch)
tree184b5b4145aa0fc93208d4c43e4f7927b1557b22 /dev-db
parentdev-libs/freexl: always build XML support (diff)
downloadgentoo-45b8c3f13cd57daf17fe0c8d7a5752af43bcc248.tar.gz
gentoo-45b8c3f13cd57daf17fe0c8d7a5752af43bcc248.tar.bz2
gentoo-45b8c3f13cd57daf17fe0c8d7a5752af43bcc248.zip
dev-db/spatialite: fixup freexl dep, require XML
We need freexl's XML support for freexl_open_ods but also doesn't make sense to have optional XML in spatialite as then feels like USE="-xml" but with XLS support isn't tested much upstream. Closes: https://bugs.gentoo.org/920326 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/spatialite/spatialite-5.1.0-r1.ebuild (renamed from dev-db/spatialite/spatialite-5.1.0.ebuild)12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-db/spatialite/spatialite-5.1.0.ebuild b/dev-db/spatialite/spatialite-5.1.0-r1.ebuild
index bf5f79f8f622..a509af0c9b1a 100644
--- a/dev-db/spatialite/spatialite-5.1.0.ebuild
+++ b/dev-db/spatialite/spatialite-5.1.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,17 +14,17 @@ S="${WORKDIR}/${MY_P}"
LICENSE="MPL-1.1"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
-IUSE="+geos iconv +proj rttopo test +xls +xml"
+IUSE="+geos iconv +proj rttopo test +xls"
# Further poking required
RESTRICT="test"
RDEPEND="
>=dev-db/sqlite-3.7.5:3[extensions(+)]
+ dev-libs/libxml2
sys-libs/zlib[minizip]
geos? ( >=sci-libs/geos-3.11.0 )
proj? ( sci-libs/proj:= )
- xls? ( >=dev-libs/freexl-2.0.0 )
- xml? ( dev-libs/libxml2 )
+ xls? ( >=dev-libs/freexl-2.0.0[xml(+)] )
rttopo? ( sci-geosciences/librttopo )
"
DEPEND="${RDEPEND}"
@@ -38,6 +38,7 @@ src_configure() {
--disable-examples \
--disable-static \
--enable-epsg \
+ --enable-libxml2 \
$(use_enable rttopo) \
$(use_enable geos) \
$(use_enable geos geosadvanced) \
@@ -45,8 +46,7 @@ src_configure() {
$(use_enable geos geos3110) \
$(use_enable iconv) \
$(use_enable proj) \
- $(use_enable xls freexl) \
- $(use_enable xml libxml2)
+ $(use_enable xls freexl)
}
src_install() {