summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2021-03-18 18:04:36 +0100
committerAgostino Sarubbo <ago@gentoo.org>2021-03-18 18:04:36 +0100
commitb1985df670f7d20c117f1e5189560493bbde7a96 (patch)
tree5c10d929b3a8d378eb889085c01c5d21168adcce /dev-db/pg_activity
parentsys-kernel/gentoo-sources: Linux patch 5.10.24 (diff)
downloadgentoo-b1985df670f7d20c117f1e5189560493bbde7a96.tar.gz
gentoo-b1985df670f7d20c117f1e5189560493bbde7a96.tar.bz2
gentoo-b1985df670f7d20c117f1e5189560493bbde7a96.zip
dev-db/pg_activity: version bump to 2.1.3 - enable tests
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'dev-db/pg_activity')
-rw-r--r--dev-db/pg_activity/Manifest1
-rw-r--r--dev-db/pg_activity/pg_activity-2.1.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-db/pg_activity/Manifest b/dev-db/pg_activity/Manifest
index 1f1ee2f5b0ce..b84706377475 100644
--- a/dev-db/pg_activity/Manifest
+++ b/dev-db/pg_activity/Manifest
@@ -1 +1,2 @@
DIST pg_activity-1.6.2.tar.gz 127561 BLAKE2B 5ddebd3068ddc33196903892c01b947ffc50ecff7ec790e196626e87ee8933ff79242e3ba61c207ea1020535c5d85dbbc4ac9e4825a19ab98004bb27ea0b6a6c SHA512 fd743f369201c6ec3762373c39969b2b7632d79a8fb9c8ebd12a88b66b91915c30e445e93162844b4a176cf7e13009c9c8136e973180b00e7cc708ecd66b4853
+DIST pg_activity-2.1.3.tar.gz 277297 BLAKE2B 9677ebad581e2e66e266e5433454e054274693a8e2e5a959c5f807ec1641f3b02a4c202eac7bddb7abe7e51e131d32d25a513a439e97aca996e79be6e1e9c0be SHA512 e28c75d1b88f6b530820d82327d6428d2388341bd09ba4efec5e80e753aee17e995b4e6d5ee8b35b3b972f20aa1228d525fe0c4bdcb8e365795d568a4a25c076
diff --git a/dev-db/pg_activity/pg_activity-2.1.3.ebuild b/dev-db/pg_activity/pg_activity-2.1.3.ebuild
new file mode 100644
index 000000000000..745e50c6b85f
--- /dev/null
+++ b/dev-db/pg_activity/pg_activity-2.1.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Realtime PostgreSQL database server monitoring tool"
+HOMEPAGE="https://github.com/dalibo/pg_activity"
+SRC_URI="https://github.com/dalibo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="POSTGRESQL"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/blessed[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # https://github.com/dalibo/pg_activity/issues/201
+ export COLUMNS="80"
+ epytest -k 'not test_ui.txt'
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/man/${PN}.1
+}