summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsin-ack <sin-ack@protonmail.com>2024-11-10 20:52:06 +0100
committerSam James <sam@gentoo.org>2024-11-11 22:24:16 +0000
commit851e0c38bfb17f5f0a93f71126806d962a140338 (patch)
tree4935b336b05533fda58cf34243951283f0c8aa28 /dev-cpp
parentdev-cpp/folly: add 2024.11.04.00 (diff)
downloadgentoo-851e0c38bfb17f5f0a93f71126806d962a140338.tar.gz
gentoo-851e0c38bfb17f5f0a93f71126806d962a140338.tar.bz2
gentoo-851e0c38bfb17f5f0a93f71126806d962a140338.zip
dev-cpp/fizz: new package, add 2024.11.04.00
Signed-off-by: sin-ack <sin-ack@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/fizz/Manifest1
-rw-r--r--dev-cpp/fizz/fizz-2024.11.04.00.ebuild51
-rw-r--r--dev-cpp/fizz/metadata.xml15
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-cpp/fizz/Manifest b/dev-cpp/fizz/Manifest
new file mode 100644
index 000000000000..cfcd6fbbd6e1
--- /dev/null
+++ b/dev-cpp/fizz/Manifest
@@ -0,0 +1 @@
+DIST fizz-2024.11.04.00.gh.tar.gz 736821 BLAKE2B af8ecc3f78dfc98d854b402f3e44f8be7b57684d09a34c4a6a19d7c47d7663cc835f27328ed0ee0a25465e7d8dbbb46c8f8085c0b9da7948c99aaf868c8c1fcc SHA512 004665bca243ac835be3628e2196450fee30852e414b068ae98555193c3e9788800536a6280e218614df89061c3f05e501dfd89f08f3c5ba3942c3e9d476bf2c
diff --git a/dev-cpp/fizz/fizz-2024.11.04.00.ebuild b/dev-cpp/fizz/fizz-2024.11.04.00.ebuild
new file mode 100644
index 000000000000..f14c4392583c
--- /dev/null
+++ b/dev-cpp/fizz/fizz-2024.11.04.00.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# These must be bumped together:
+# dev-cpp/edencommon
+# dev-cpp/fb303
+# dev-cpp/fbthrift
+# dev-cpp/fizz
+# dev-cpp/folly
+# dev-cpp/mvfst
+# dev-cpp/wangle
+# dev-util/watchman
+
+CMAKE_USE_DIR="${S}/fizz"
+
+inherit cmake
+
+DESCRIPTION="C++14 implementation of the TLS-1.3 standard"
+HOMEPAGE="https://github.com/facebookincubator/fizz"
+SRC_URI="https://github.com/facebookincubator/fizz/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-arch/zstd:=
+ ~dev-cpp/folly-${PV}:=
+ dev-cpp/gflags:=
+ dev-cpp/glog:=[gflags]
+ dev-libs/libsodium:=
+ dev-libs/openssl:=
+"
+uEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DIR="$(get_libdir)/cmake/${PN}"
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ -DBUILD_TESTS="$(usex test ON OFF)"
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-cpp/fizz/metadata.xml b/dev-cpp/fizz/metadata.xml
new file mode 100644
index 000000000000..7d721ebf3773
--- /dev/null
+++ b/dev-cpp/fizz/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>sin-ack@protonmail.com</email>
+ <name>sin-ack</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">facebookincubator/fizz</remote-id>
+ </upstream>
+</pkgmetadata>