summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-08-28 19:17:26 +0200
committerUlrich Müller <ulm@gentoo.org>2024-08-28 19:21:14 +0200
commit0e1afff6e6674ec9bef5f6a346f51efe4d082ab7 (patch)
treea1e6d9dc18fd5146d8a32bf3d47052f23d7d5f20 /app-xemacs
parentapp-emacs/ebuild-mode: add 1.74 (diff)
downloadgentoo-0e1afff6e6674ec9bef5f6a346f51efe4d082ab7.tar.gz
gentoo-0e1afff6e6674ec9bef5f6a346f51efe4d082ab7.tar.bz2
gentoo-0e1afff6e6674ec9bef5f6a346f51efe4d082ab7.zip
app-xemacs/ebuild-mode: add 1.74
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-xemacs')
-rw-r--r--app-xemacs/ebuild-mode/Manifest1
-rw-r--r--app-xemacs/ebuild-mode/ebuild-mode-1.74.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-xemacs/ebuild-mode/Manifest b/app-xemacs/ebuild-mode/Manifest
index 9925c457e4e4..fc685eab65dc 100644
--- a/app-xemacs/ebuild-mode/Manifest
+++ b/app-xemacs/ebuild-mode/Manifest
@@ -1,2 +1,3 @@
DIST ebuild-mode-1.72.tar.xz 41968 BLAKE2B 24170aa6f23022f47707445eebbb7272c898fa8ca922d0a1ee57962ccc9feed6ea608661998e3f812a0b5fcc8ce8d8ff0baa890505dad846e0dc4b5c9e0b4236 SHA512 7f2234f9f5053f9588fb25d673dbce10a9d6e5c056ea7dabf04ffe5a0f8da7064b81829229339c5d98ee7ce840eb6c8b9ec24fcfd3dee2d5b798b5e6adb81e10
DIST ebuild-mode-1.73.tar.xz 45264 BLAKE2B 115f67f9bfbf80ce5ddda1cc1dfee62aec15cb66c694b634361762c47c8c5afa6cdf0bc6c374440e939accbe9b13df0a84a7957b8c8c72a13324d2544388124a SHA512 855fdd0c94da77bae8f948fbc02782d47a0982e4a3d8ccff5d77a9c6b1f55b80a78144b493e5949e04b196cf8ee95e1fcc0b84c6ecace1a7d687ed6733d25820
+DIST ebuild-mode-1.74.tar.xz 48480 BLAKE2B f9277473af5610039d2a2f46bdebf79e266dca140c93407d304e746088d6f4df2b492a42918754ebba7abb78fa2c116f621684f93c5df98fc7a86c519755a906 SHA512 35d14987719675122f7f17c76a1fa7ab51f4789e3eb50630d610ea98066ae7091b4f8b8c210874be18b2848e925e2e15f2d25e3d41ae702be9ce7ae28b444db2
diff --git a/app-xemacs/ebuild-mode/ebuild-mode-1.74.ebuild b/app-xemacs/ebuild-mode/ebuild-mode-1.74.ebuild
new file mode 100644
index 000000000000..b51f882d3b80
--- /dev/null
+++ b/app-xemacs/ebuild-mode/ebuild-mode-1.74.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=app-editors/xemacs-21.4.24-r9
+ app-xemacs/sh-script"
+BDEPEND="${RDEPEND}
+ test? ( >=app-editors/xemacs-21.5.35 )"
+
+EMACS="${EPREFIX}/usr/bin/xemacs"
+EMACSFLAGS="-batch -q --no-site-file"
+
+src_compile() {
+ ${EMACS} ${EMACSFLAGS} \
+ -eval "(add-to-list 'load-path nil)" \
+ -f batch-byte-compile \
+ ebuild-mode.el gentoo-newsitem-mode.el || die
+
+ ${EMACS} ${EMACSFLAGS} \
+ -eval "(setq autoload-package-name \"${PN}\")" \
+ -eval "(setq generated-autoload-file \"${S}/auto-autoloads.el\")" \
+ -l autoload -f batch-update-autoloads \
+ ebuild-mode.el gentoo-newsitem-mode.el || die
+}
+
+src_test() {
+ emake check EMACS="${EMACS}" EMACSFLAGS="${EMACSFLAGS}"
+}
+
+src_install() {
+ insinto /usr/lib/xemacs/site-packages/lisp/${PN}
+ doins ebuild-mode.{el,elc} gentoo-newsitem-mode.{el,elc}
+ doins auto-autoloads.el
+}
+
+pkg_postinst() {
+ optfeature "ebuild commands support" sys-apps/portage
+ optfeature "additional development tools" dev-util/pkgdev
+ optfeature "ebuild QA utilities" dev-util/pkgcheck
+}