summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-08-28 10:57:34 +0200
committerPatrice Clement <monsieurp@gentoo.org>2022-08-28 16:29:46 +0200
commit46fd44c8fa2a1aab6ff10e2728b20024e7dcf449 (patch)
tree3e42ed90c0bb74ec2937d4eeec9c74beac817d00 /app-vim
parentapp-crypt/ima-evm-utils: drop 1.1-r1, 1.3.2, EAPI-6-- (diff)
downloadgentoo-46fd44c8fa2a1aab6ff10e2728b20024e7dcf449.tar.gz
gentoo-46fd44c8fa2a1aab6ff10e2728b20024e7dcf449.tar.bz2
gentoo-46fd44c8fa2a1aab6ff10e2728b20024e7dcf449.zip
app-vim/vimclojure: update EAPI 6 -> 8
Bug: https://bugs.gentoo.org/850067 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/27040 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimclojure/vimclojure-2.3.6-r4.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-vim/vimclojure/vimclojure-2.3.6-r4.ebuild b/app-vim/vimclojure/vimclojure-2.3.6-r4.ebuild
new file mode 100644
index 000000000000..c34730afe916
--- /dev/null
+++ b/app-vim/vimclojure/vimclojure-2.3.6-r4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+MY_PN="VimClojure"
+
+DESCRIPTION="vim plugin: Clojure syntax highlighting, filetype and indent settings"
+HOMEPAGE="https://github.com/vim-scripts/VimClojure"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-lang/clojure"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS=( README README.markdown )
+
+# Files with similar names are already installed by app-vim/slimv.
+DUPLICATE_FILES=(
+ indent/clojure.vim
+ ftdetect/clojure.vim
+)
+
+src_prepare() {
+ default
+
+ # Remove .bat files.
+ find . -type f -name \*.bat -exec rm -v {} \; || die
+
+ # Let's simply rename ${DUPLICATE_FILES[@]}.
+ local f
+ for f in "${DUPLICATE_FILES[@]}"; do
+ [[ -f "${f}" ]] || die "Couldn't find ${f}"
+ bname="${f##*/}"
+ path="${f%/*}"
+ noext="${bname%%.*}"
+ newname="${path}/${PN}_${noext}.vim"
+ mv -v "${f}" "${newname}" || die
+ done
+}
+
+src_install() {
+ rm -rv doc/LICENSE.txt bin || die
+ vim-plugin_src_install
+}