summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-01-14 19:45:32 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-01-20 22:21:43 +0100
commit3e55f730c5f73b2e14d38a86ab74a4b50c7d9600 (patch)
tree1d85cbcb3b5672547387255f9d5a2d3e3d327ac3 /app-vim
parentapp-vim/pathogen: fix whitespace (diff)
downloadgentoo-3e55f730c5f73b2e14d38a86ab74a4b50c7d9600.tar.gz
gentoo-3e55f730c5f73b2e14d38a86ab74a4b50c7d9600.tar.bz2
gentoo-3e55f730c5f73b2e14d38a86ab74a4b50c7d9600.zip
app-vim/tagbar: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/tagbar/tagbar-2.7-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/app-vim/tagbar/tagbar-2.7-r1.ebuild b/app-vim/tagbar/tagbar-2.7-r1.ebuild
new file mode 100644
index 000000000000..d3ad7238cf7f
--- /dev/null
+++ b/app-vim/tagbar/tagbar-2.7-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: display tags of the current file ordered by scope"
+HOMEPAGE="
+ https://github.com/preservim/tagbar
+ https://www.vim.org/scripts/script.php?script_id=3465
+"
+SRC_URI="https://github.com/preservim/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-util/ctags-5.5"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"