summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-10-02 01:35:50 -0400
committerZac Medico <zmedico@gentoo.org>2023-10-17 21:25:58 -0700
commit0c7dd1f7d5dbf2e129b50b870a6f208a724cbaaf (patch)
tree042c04afb9c6b2e0dcb04ca39e6f701c1b7bd6d3 /app-text
parentapp-text/calibre: remove outdated workarounds for xdg install steps (diff)
downloadgentoo-0c7dd1f7d5dbf2e129b50b870a6f208a724cbaaf.tar.gz
gentoo-0c7dd1f7d5dbf2e129b50b870a6f208a724cbaaf.tar.bz2
gentoo-0c7dd1f7d5dbf2e129b50b870a6f208a724cbaaf.zip
app-text/calibre: avoid setting useless variables at install time
The install process does not rerun compiles, so setting variables there is useless and does nothing. They didn't have any effect on src_compile all this time, which means that whatever they tried to fix clearly was not an issue. ;) That being said, there are two things going on here: - OVERRIDE_CFLAGS is used by the calibre build system in addition to CFLAGS, so it is not actually necessary to override it, and using both, means using -Wall and suchlike so respecting it seems reasonable - the calibre build system respects either $PATH or $QMAKE to find the qmake program. Instead of using the former method in src_compile and the latter method in src_install, just use the latter method in src_compile and avoid munging $PATH. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/calibre/calibre-5.44.0-r2.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/app-text/calibre/calibre-5.44.0-r2.ebuild b/app-text/calibre/calibre-5.44.0-r2.ebuild
index 759f990001f0..598bb98f4356 100644
--- a/app-text/calibre/calibre-5.44.0-r2.ebuild
+++ b/app-text/calibre/calibre-5.44.0-r2.ebuild
@@ -183,8 +183,9 @@ src_compile() {
# bug 821871
local MY_LIBDIR="${ESYSROOT}/usr/$(get_libdir)"
export FT_LIB_DIR="${MY_LIBDIR}" HUNSPELL_LIB_DIR="${MY_LIBDIR}" PODOFO_LIB_DIR="${MY_LIBDIR}"
+ export QMAKE="$(qt5_get_bindir)/qmake"
- PATH="${T}/bin:$(qt5_get_bindir):${PATH}" ${EPYTHON} setup.py build || die
+ ${EPYTHON} setup.py build || die
}
src_test() {
@@ -202,8 +203,6 @@ src_test() {
}
src_install() {
- export QMAKE="$(qt5_get_bindir)/qmake"
-
# Bug #352625 - Some LANGUAGE values can trigger the following ValueError:
# File "/usr/lib/python2.6/locale.py", line 486, in getdefaultlocale
# return _parse_localename(localename)
@@ -219,9 +218,6 @@ src_install() {
export CALIBRE_CONFIG_DIRECTORY="${HOME}/.config/calibre"
mkdir -p "${CALIBRE_CONFIG_DIRECTORY}" || die
- tc-export CC CXX
- # Bug #334243 - respect LDFLAGS when building extensions
- export OVERRIDE_CFLAGS="$CFLAGS" OVERRIDE_LDFLAGS="$LDFLAGS"
local libdir=$(get_libdir)
[[ -n $libdir ]] || die "get_libdir returned an empty string"