summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-02-24 16:38:09 +0000
committerMarek Szuba <marecki@gentoo.org>2023-02-24 16:50:00 +0000
commitcdf8988f51efe0c097a3f9b48c90698032b76371 (patch)
tree59456f51571e4e7dbe306b16ec6db86a456eb0c0 /app-text/xiphos
parentmedia-libs/aalib: update HOMEPAGE (diff)
downloadgentoo-cdf8988f51efe0c097a3f9b48c90698032b76371.tar.gz
gentoo-cdf8988f51efe0c097a3f9b48c90698032b76371.tar.bz2
gentoo-cdf8988f51efe0c097a3f9b48c90698032b76371.zip
app-text/xiphos: migrate to net-libs/webkit-gtk:4.1
Builds without errors against this version. Closes: https://bugs.gentoo.org/893684 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-text/xiphos')
-rw-r--r--app-text/xiphos/files/xiphos-4.2.1-webkit41.patch20
-rw-r--r--app-text/xiphos/xiphos-4.2.1-r2.ebuild73
2 files changed, 93 insertions, 0 deletions
diff --git a/app-text/xiphos/files/xiphos-4.2.1-webkit41.patch b/app-text/xiphos/files/xiphos-4.2.1-webkit41.patch
new file mode 100644
index 000000000000..8de40e28c64e
--- /dev/null
+++ b/app-text/xiphos/files/xiphos-4.2.1-webkit41.patch
@@ -0,0 +1,20 @@
+--- a/cmake/XiphosDependencies.cmake
++++ b/cmake/XiphosDependencies.cmake
+@@ -84,7 +84,7 @@
+ "gdk-pixbuf-2.0"
+ "gio-2.0"
+ "gobject-2.0"
+- "libsoup-2.4"
++ "libsoup-3.0"
+ "pango"
+ "minizip"
+ "zlib"
+@@ -144,7 +144,7 @@
+ # Gtk+-3.0 + Webkit2 + GtkHtml-editor
+ pkg_check_modules(Gtk REQUIRED IMPORTED_TARGET
+ "gtk+-3.0"
+- "webkit2gtk-4.0"
++ "webkit2gtk-4.1"
+ )
+ endif()
+ endif (GTK2)
diff --git a/app-text/xiphos/xiphos-4.2.1-r2.ebuild b/app-text/xiphos/xiphos-4.2.1-r2.ebuild
new file mode 100644
index 000000000000..04e20aca65b1
--- /dev/null
+++ b/app-text/xiphos/xiphos-4.2.1-r2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="A Gtk+-based Bible-study frontend for SWORD"
+HOMEPAGE="https://xiphos.org/"
+SRC_URI="https://github.com/crosswire/${PN}/releases/download/${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~marecki/dists/${CATEGORY}/${PN}/${PN}-4.2.1-disable_webkit_editor.patch.xz"
+
+LICENSE="GPL-2 FDL-1.1 LGPL-2 MIT MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="dbus debug"
+
+COMMON="sys-apps/util-linux
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dbus? ( dev-libs/dbus-glib )"
+RDEPEND="${COMMON}
+ >=app-text/sword-1.8.1
+ dev-libs/glib:2
+ dev-libs/icu
+ >=net-libs/biblesync-1.2.0
+ net-libs/webkit-gtk:4.1
+ sys-libs/zlib[minizip]
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}"
+BDEPEND="${COMMON}
+ app-arch/zip
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ dev-util/glib-utils
+ dev-util/itstool
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${WORKDIR}"/${PN}-4.2.1-disable_webkit_editor.patch
+ "${FILESDIR}"/${PN}-4.2.1-appdata_metainfo.patch
+ "${FILESDIR}"/${PN}-4.2.1-glib_version_min_required.patch
+ "${FILESDIR}"/${PN}-4.2.1-webkit41.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDBUS=$(usex dbus)
+ -DDEBUG=$(usex debug)
+ -DPOSTINST=off
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ local rver
+ for rver in ${REPLACING_VERSIONS}; do
+ if ver_test "${rver}" -le "4.2.1"; then
+ ewarn "Please note that ${PN} no longer provides an editor due to its dependency on outdated libraries."
+ ewarn "Studypad and the personal commentary will no longer work."
+ break
+ fi
+ done
+ fi
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}