summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-24 00:16:17 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-24 00:18:44 +0100
commitc47fdcc36ce2a93af8ad40b208123ba541a59f8d (patch)
tree40daef9f99c1fc1ae6d0a9ff00567044d46a137c /app-text/tkman
parentsys-kernel/gentoo-kernel-bin: add 5.14.21-r1 for arm64 (diff)
downloadgentoo-c47fdcc36ce2a93af8ad40b208123ba541a59f8d.tar.gz
gentoo-c47fdcc36ce2a93af8ad40b208123ba541a59f8d.tar.bz2
gentoo-c47fdcc36ce2a93af8ad40b208123ba541a59f8d.zip
app-text/tkman: update EAPI 5 -> 8
Now with actually working installation of the HTML manual! Bug: https://bugs.gentoo.org/826394 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-text/tkman')
-rw-r--r--app-text/tkman/tkman-2.2-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-text/tkman/tkman-2.2-r2.ebuild b/app-text/tkman/tkman-2.2-r2.ebuild
new file mode 100644
index 000000000000..6db7c4e92700
--- /dev/null
+++ b/app-text/tkman/tkman-2.2-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="Graphical, hypertex man and info page browser"
+HOMEPAGE="https://sourceforge.net/projects/tkman/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="
+ >=app-text/rman-3.1
+ >=dev-lang/tcl-8.4:0
+ >=dev-lang/tk-8.4:0
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2-gentoo.diff \
+ "${FILESDIR}"/${PN}-CVE-2008-5137.diff
+)
+
+src_install() {
+ local DOCS=( ANNOUNCE-tkman.txt CHANGES README-tkman )
+ local HTML_DOCS=( manual.html )
+
+ dodir /usr/bin
+ default
+
+ doicon contrib/TkMan.gif
+
+ domenu "${FILESDIR}"/tkman.desktop
+}