summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-03-15 18:45:39 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-03-15 18:45:39 +0200
commit37c614b50a5ead52c92ae5ef5b1257050c2a21d4 (patch)
tree768d5cc5d2a673736e145032e1c8ac4fa1d51771 /app-text/sigil
parentmedia-plugins/alsa-plugins: Stabilize 1.2.7.1-r1 ppc64, #891847 (diff)
downloadgentoo-37c614b50a5ead52c92ae5ef5b1257050c2a21d4.tar.gz
gentoo-37c614b50a5ead52c92ae5ef5b1257050c2a21d4.tar.bz2
gentoo-37c614b50a5ead52c92ae5ef5b1257050c2a21d4.zip
app-text/sigil: add 1.9.30
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-text/sigil')
-rw-r--r--app-text/sigil/Manifest1
-rw-r--r--app-text/sigil/sigil-1.9.30.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/app-text/sigil/Manifest b/app-text/sigil/Manifest
index 4c1a8f8e9572..b958473718dc 100644
--- a/app-text/sigil/Manifest
+++ b/app-text/sigil/Manifest
@@ -1 +1,2 @@
DIST sigil-1.9.20.tar.gz 25139664 BLAKE2B ca0a8ba5ec9b76ea4016766872e7a70d839c2b3f24a658e90e619fd2feb01de74e05e30cdcf53c79ce92196c380da1d348ec2776f77060b18d2c664ff8171c6a SHA512 07aff142f65084b7900b25b089fca1d9a36022e690acaf0db3c7b2eb310a847834baff42884e73bbe6b31ff2dd7f73e76819c5c7a4292578fbea2edcebec5ad1
+DIST sigil-1.9.30.tar.gz 26602897 BLAKE2B 554af2aa4c26994c065023839ea29b190eea501cac1183d58dcf2439ebca89e0a56848aaec1d668cfb84555c6830eaf6d32efdc82b08e0c94d7b6ba95dd7ff8b SHA512 80dcaa9dcee51c36a42bcd57fc87acda94002af74602d934c7e9bfd275339d9ac200cd1f141fb9e2709ac054569bc22f1869623498ce16c636a3fab8dae4e70f
diff --git a/app-text/sigil/sigil-1.9.30.ebuild b/app-text/sigil/sigil-1.9.30.ebuild
new file mode 100644
index 000000000000..4574fdd28962
--- /dev/null
+++ b/app-text/sigil/sigil-1.9.30.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="tk"
+
+inherit xdg cmake python-single-r1
+
+DESCRIPTION="Multi-platform WYSIWYG ebook editor for ePub format"
+HOMEPAGE="https://sigil-ebook.com/ https://github.com/Sigil-Ebook/Sigil"
+SRC_URI="https://github.com/Sigil-Ebook/Sigil/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="GPL-3+ Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+plugins system-mathjax"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-text/hunspell:=
+ dev-libs/libpcre2:=[pcre16]
+ $(python_gen_cond_dep '
+ dev-python/css-parser[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]')
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwebengine:5[widgets]
+ dev-qt/qtwidgets:5
+ sys-libs/zlib[minizip]
+ plugins? ( $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/dulwich[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]') )
+ system-mathjax? ( dev-libs/mathjax )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-qt/linguist-tools:5
+"
+
+DOCS=( ChangeLog.txt README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DTRY_NEWER_FINDPYTHON3=1
+ -DPython3_INCLUDE_DIR="$(python_get_includedir)"
+ -DPython3_LIBRARY="$(python_get_library_path)"
+ -DPython3_EXECUTABLE="${PYTHON}"
+
+ -DINSTALL_BUNDLED_DICTS=0
+ -DSYSTEM_LIBS_REQUIRED=1
+ -DUSE_SYSTEM_LIBS=1
+ -DUSE_QT6=0
+ )
+ use system-mathjax && mycmakeargs+=( -DMATHJAX_DIR="${EPREFIX}"/usr/share/mathjax )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_fix_shebang "${ED}"/usr/share/sigil/
+ python_optimize "${ED}"/usr/share/sigil/
+}