summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-03 19:08:07 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-03 21:35:50 +0100
commit6fa94256b54e19e97ea5eaac37397ec30f62338e (patch)
tree5808186c76a103394b4468f9d2434912be88bc2a /app-text/poppler
parentkde-frameworks/kwallet: drop 6.7.0 (diff)
downloadgentoo-6fa94256b54e19e97ea5eaac37397ec30f62338e.tar.gz
gentoo-6fa94256b54e19e97ea5eaac37397ec30f62338e.tar.bz2
gentoo-6fa94256b54e19e97ea5eaac37397ec30f62338e.zip
app-text/poppler: 24.11.0 version bump w/o KEYWORDS, subslot bump
Header cleanup in upstream commit 4a7665d5 causing yet more trouble, at least with Scribus. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/poppler')
-rw-r--r--app-text/poppler/Manifest2
-rw-r--r--app-text/poppler/poppler-24.11.0.ebuild157
-rw-r--r--app-text/poppler/poppler-9999.ebuild2
3 files changed, 160 insertions, 1 deletions
diff --git a/app-text/poppler/Manifest b/app-text/poppler/Manifest
index f43348b92ae4..30b2218f8fd7 100644
--- a/app-text/poppler/Manifest
+++ b/app-text/poppler/Manifest
@@ -6,4 +6,6 @@ DIST poppler-24.09.0.tar.xz 1914488 BLAKE2B be6a388b9ca80aa6d86f05a69e712f5db876
DIST poppler-24.09.0.tar.xz.sig 833 BLAKE2B 01c532ac962133ab85de72520a558b5f67ab27e8c260097b40a633f0f51978562c0ded7230828424712dbb931032d02d18179090fbc80dc926c1d58e8c32c2c2 SHA512 612b7b8a69ef4feb05c029cf925e5e876697abef4ee01575c3cfe68f20f7acd10103e18705c56f7c199707df648523553a6c87b8f39287ace03e444abf8750f2
DIST poppler-24.10.0.tar.xz 1920580 BLAKE2B 5eee232c64f18083fa189b1839a7757c34f31a8711c4f173bfe0ded7c08d96618c9276fade85b3802cc79e31ca4b22f425904102f52a42985c9506f9cefbcf9f SHA512 5515b4c439cd2e92119aedcb8960dd82e6f78a1ffd82543d3649bedb3e0e8e97689ea592f4df347cc3c97d5d90c8518c13859f80be25f157b9aea78e62a31502
DIST poppler-24.10.0.tar.xz.sig 833 BLAKE2B 241d939ab41687f3a5133418630624cc50f0de4cd00d45b3c7d2ea7afa083ac33b7dbb40a3493743bc6c5ba04f1c82c4bb0acae64f2f8658190fb7587a0097c3 SHA512 1c3668c8092bafe4169c2945b0bb2eeb1ab20097e1a45496837f2ce4edb4651272920583606b1746998a9313da6227814ffbbd22eb06195b21219673a9957a6e
+DIST poppler-24.11.0.tar.xz 1922804 BLAKE2B 2ee77ddfd49ab4b3f486fcd160be21fdf2d474e44b6cdfd40a7f927cbe253d407a6f75b66de83ab541288a54558445e409b283a81c7a8ff20f9a6d0d4f33adf7 SHA512 3823c024d9b1cab7c4ee8a99d5209722296cce8894e3f4ba8d5a84ab6bba430fa0c1078bfcddcdbc1c30bd98832e269df2aef1d5af20c1985b9f903cb70a24e7
+DIST poppler-24.11.0.tar.xz.sig 833 BLAKE2B 7ef6e5bd5659c91dc5924367b7875a3946116a71b0cc02d98a1cccd51d4a46b8d8b219681e576ba7ea27f736c8a5220ae98acb0f454ac4785c03d1c66d104046 SHA512 7b935eaa99c4c3e8706bfcb010245babf5a4f08f6809a340239a0c40eed0a79472c34e4722d4b480e20fa6618106cc5e9583e209e025689f1fae06c5c499f95f
DIST poppler-test-ff3133cdb6cb496ee1d2c3231bfa35006a5e8410.tar.bz2 5207226 BLAKE2B 15153457989a53301bcdc3468ab2b06b637457199004651b39ea848f488f8a2ba594ce2e36091de4fd06fc0a52b783c6b2ee243ac5d95ce1e9db7483ea880829 SHA512 335cd3d55fc6e28331e791e5b63a08d293abc70764a9f314b2c590c26a5a78b38243c74f988bb95afffe0bdcc54dee1e633dbf1672b19a290be40a298e16995f
diff --git a/app-text/poppler/poppler-24.11.0.ebuild b/app-text/poppler/poppler-24.11.0.ebuild
new file mode 100644
index 000000000000..054f0ab434e4
--- /dev/null
+++ b/app-text/poppler/poppler-24.11.0.ebuild
@@ -0,0 +1,157 @@
+# Copyright 2005-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic toolchain-funcs xdg-utils
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/poppler/poppler"
+ SLOT="0/9999"
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/aacid.asc
+ inherit verify-sig
+
+ TEST_COMMIT="ff3133cdb6cb496ee1d2c3231bfa35006a5e8410"
+ SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
+ SRC_URI+=" test? ( https://gitlab.freedesktop.org/poppler/test/-/archive/${TEST_COMMIT}/test-${TEST_COMMIT}.tar.bz2 -> ${PN}-test-${TEST_COMMIT}.tar.bz2 )"
+ SRC_URI+=" verify-sig? ( https://poppler.freedesktop.org/${P}.tar.xz.sig )"
+# KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+ SLOT="0/143" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+fi
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="https://poppler.freedesktop.org/"
+
+LICENSE="GPL-2"
+IUSE="boost cairo cjk curl +cxx debug doc gpgme +introspection +jpeg +jpeg2k +lcms nss png qt5 qt6 test tiff +utils"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ >=media-libs/fontconfig-2.13
+ >=media-libs/freetype-2.10
+ sys-libs/zlib
+ cairo? (
+ >=dev-libs/glib-2.64:2
+ >=x11-libs/cairo-1.16
+ introspection? ( >=dev-libs/gobject-introspection-1.72:= )
+ )
+ curl? ( net-misc/curl )
+ gpgme? ( >=app-crypt/gpgme-1.19.0:=[cxx] )
+ jpeg? ( >=media-libs/libjpeg-turbo-1.1.0:= )
+ jpeg2k? ( >=media-libs/openjpeg-2.3.0-r1:2= )
+ lcms? ( media-libs/lcms:2 )
+ nss? ( >=dev-libs/nss-3.49 )
+ png? ( media-libs/libpng:0= )
+ qt5? (
+ >=dev-qt/qtcore-5.15.2:5
+ >=dev-qt/qtgui-5.15.2:5
+ >=dev-qt/qtxml-5.15.2:5
+ )
+ qt6? ( dev-qt/qtbase:6[gui,xml] )
+ tiff? ( media-libs/tiff:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ cjk? ( app-text/poppler-data )
+"
+DEPEND="${COMMON_DEPEND}
+ boost? ( >=dev-libs/boost-1.74 )
+ test? (
+ qt5? (
+ >=dev-qt/qttest-5.15.2:5
+ >=dev-qt/qtwidgets-5.15.2:5
+ )
+ qt6? ( dev-qt/qtbase:6[widgets] )
+ )
+"
+BDEPEND="
+ >=dev-util/glib-utils-2.64
+ virtual/pkgconfig
+"
+
+if [[ ${PV} != *9999* ]] ; then
+ BDEPEND+=" verify-sig? ( >=sec-keys/openpgp-keys-aacid-20230907 )"
+fi
+
+DOCS=( AUTHORS NEWS README.md README-XPDF )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-23.10.0-qt-deps.patch"
+ "${FILESDIR}/${PN}-21.09.0-respect-cflags.patch"
+ "${FILESDIR}/${PN}-0.57.0-disable-internal-jpx.patch"
+)
+
+src_unpack() {
+ if [[ ${PV} == *9999* ]] ; then
+ git-r3_src_unpack
+ elif use verify-sig ; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ fi
+
+ default
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Clang doesn't grok this flag, the configure nicely tests that, but
+ # cmake just uses it, so remove it if we use clang
+ if tc-is-clang ; then
+ sed -e 's/-fno-check-new//' -i cmake/modules/PopplerMacros.cmake || die
+ fi
+
+ if ! grep -Fq 'cmake_policy(SET CMP0002 OLD)' CMakeLists.txt ; then
+ sed -e '/^cmake_minimum_required/acmake_policy(SET CMP0002 OLD)' \
+ -i CMakeLists.txt || die
+ else
+ einfo "policy(SET CMP0002 OLD) - workaround can be removed"
+ fi
+}
+
+src_configure() {
+ xdg_environment_reset
+ append-lfs-flags # bug #898506
+
+ local mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT5_TESTS=$(usex test $(usex qt5))
+ -DBUILD_QT6_TESTS=$(usex test $(usex qt6))
+ -DBUILD_CPP_TESTS=$(usex test)
+ -DBUILD_MANUAL_TESTS=$(usex test)
+ -DTESTDATADIR="${WORKDIR}"/test-${TEST_COMMIT}
+ -DRUN_GPERF_IF_PRESENT=OFF
+ -DENABLE_BOOST="$(usex boost)"
+ -DENABLE_ZLIB_UNCOMPRESS=OFF
+ -DENABLE_UNSTABLE_API_ABI_HEADERS=ON
+ -DUSE_FLOAT=OFF
+ -DWITH_Cairo=$(usex cairo)
+ -DENABLE_LIBCURL=$(usex curl)
+ -DENABLE_CPP=$(usex cxx)
+ -DENABLE_GPGME=$(usex gpgme)
+ -DWITH_JPEG=$(usex jpeg)
+ -DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
+ -DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)
+ -DENABLE_LCMS=$(usex lcms)
+ -DENABLE_NSS3=$(usex nss)
+ -DWITH_PNG=$(usex png)
+ -DENABLE_QT5=$(usex qt5)
+ -DENABLE_QT6=$(usex qt6)
+ -DENABLE_LIBTIFF=$(usex tiff)
+ -DENABLE_UTILS=$(usex utils)
+ )
+ use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # live version doesn't provide html documentation
+ if use cairo && use doc && [[ ${PV} != *9999* ]]; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/*
+ fi
+}
diff --git a/app-text/poppler/poppler-9999.ebuild b/app-text/poppler/poppler-9999.ebuild
index 30f9b48467a0..a721ae5cb97a 100644
--- a/app-text/poppler/poppler-9999.ebuild
+++ b/app-text/poppler/poppler-9999.ebuild
@@ -18,7 +18,7 @@ else
SRC_URI+=" test? ( https://gitlab.freedesktop.org/poppler/test/-/archive/${TEST_COMMIT}/test-${TEST_COMMIT}.tar.bz2 -> ${PN}-test-${TEST_COMMIT}.tar.bz2 )"
SRC_URI+=" verify-sig? ( https://poppler.freedesktop.org/${P}.tar.xz.sig )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
- SLOT="0/142" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+ SLOT="0/143" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
fi
DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"