summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/openlp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/openlp')
-rw-r--r--app-text/openlp/Manifest2
-rw-r--r--app-text/openlp/metadata.xml10
-rw-r--r--app-text/openlp/openlp-2.0.4.ebuild41
-rw-r--r--app-text/openlp/openlp-2.0.5.ebuild41
4 files changed, 94 insertions, 0 deletions
diff --git a/app-text/openlp/Manifest b/app-text/openlp/Manifest
new file mode 100644
index 000000000000..bdcd6531810e
--- /dev/null
+++ b/app-text/openlp/Manifest
@@ -0,0 +1,2 @@
+DIST OpenLP-2.0.4.tar.gz 5805304 SHA256 ffb66cf67b04bf0070444fd4c61fbddb5ba9e411c4fb7b4225b84418e9c25d96 SHA512 314d1ed3ff5c8ff8cf11709941fa95515a899632c210ee67bc9f08c853a8d2bd5f61743a5b2b438fdddebc3cced53fbddd1d1f93e3a4c7b1324a1af3a4e4b2c1 WHIRLPOOL 8125fd331e092daa71093e46bdf99680b5acadfae9b7dde65f0dabe7d25e55c926b98bb69807d419274218c9161b2985c06357129bf928d0fa1ed1058eaf7660
+DIST OpenLP-2.0.5.tar.gz 5806428 SHA256 d1d39282b9a55d031d98d396373416ff0216d44ed5c9f6f747501592fe94699b SHA512 643fb632a430831e8ac697fd895573d56db2c4954aefd5d06bbca39af55cbdc9788aec7366c6663a4fdbf92f0fcb4aeeeef4579b8ca41e3e65a862b322835620 WHIRLPOOL e966b00ecc8c6c067fe78c028e4ebf18256fac417f4e5685e7bc43a7e26f7392a89a44ed6784e6c648a3937dba22c89dc7d2ef94f5dddf363f8b416c255227be
diff --git a/app-text/openlp/metadata.xml b/app-text/openlp/metadata.xml
new file mode 100644
index 000000000000..4a37ec35678b
--- /dev/null
+++ b/app-text/openlp/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>anarchy@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">openlp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/openlp/openlp-2.0.4.ebuild b/app-text/openlp/openlp-2.0.4.ebuild
new file mode 100644
index 000000000000..494899057cdb
--- /dev/null
+++ b/app-text/openlp/openlp-2.0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Free church presentation software"
+HOMEPAGE="http://openlp.org/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/OpenLP-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pyodbc
+ dev-python/PyQt4[X,multimedia,phonon,webkit,${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sip[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy-migrate[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/OpenLP-${PV}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ domenu resources/openlp.desktop
+ dosym openlp.pyw /usr/bin/openlp
+ doicon -s scalable resources/images/openlp.svg
+}
diff --git a/app-text/openlp/openlp-2.0.5.ebuild b/app-text/openlp/openlp-2.0.5.ebuild
new file mode 100644
index 000000000000..494899057cdb
--- /dev/null
+++ b/app-text/openlp/openlp-2.0.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Free church presentation software"
+HOMEPAGE="http://openlp.org/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/OpenLP-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pyodbc
+ dev-python/PyQt4[X,multimedia,phonon,webkit,${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sip[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy-migrate[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/OpenLP-${PV}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ domenu resources/openlp.desktop
+ dosym openlp.pyw /usr/bin/openlp
+ doicon -s scalable resources/images/openlp.svg
+}