summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-02 21:50:59 +0000
committerSam James <sam@gentoo.org>2020-09-02 21:53:36 +0000
commit0c564292d877f05eb7ca73f951ca459586bad220 (patch)
treeb5c52843c404e7e18c9331b7cfcea1745a646d31 /app-text/llpp
parentapp-text/llpp: snapshot version p20191016 (diff)
downloadgentoo-0c564292d877f05eb7ca73f951ca459586bad220.tar.gz
gentoo-0c564292d877f05eb7ca73f951ca459586bad220.tar.bz2
gentoo-0c564292d877f05eb7ca73f951ca459586bad220.zip
app-text/llpp: port to xdg eclass
The xdg eclass has some nice detection for when we need to call the metadata/cache re-generation, so let's make use of that instead. Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/llpp')
-rw-r--r--app-text/llpp/llpp-31.ebuild29
1 files changed, 10 insertions, 19 deletions
diff --git a/app-text/llpp/llpp-31.ebuild b/app-text/llpp/llpp-31.ebuild
index 78104778ab62..439e1c537abe 100644
--- a/app-text/llpp/llpp-31.ebuild
+++ b/app-text/llpp/llpp-31.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit toolchain-funcs xdg-utils
+inherit toolchain-funcs xdg
DESCRIPTION="Graphical PDF viewer which aims to superficially resemble less(1)"
HOMEPAGE="https://github.com/moosotc/llpp"
@@ -14,24 +14,25 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="+ocamlopt static-libs"
-RDEPEND="=app-text/mupdf-1.16*:0=[static-libs?]
+BDEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig"
+RDEPEND="
+ =app-text/mupdf-1.16*:0=[static-libs?]
app-arch/bzip2[static-libs?]
media-libs/fontconfig:1.0[static-libs?]
media-libs/freetype:2[static-libs?]
media-libs/jbig2dec:=[static-libs?]
- media-libs/openjpeg:2[static-libs?]
- sys-libs/zlib[static-libs?]
+ media-libs/openjpeg:2=[static-libs?]
+ sys-libs/zlib:=[static-libs?]
virtual/jpeg:0[static-libs?]
x11-libs/libX11[static-libs?]
x11-libs/libXau[static-libs?]
x11-libs/libXdmcp[static-libs?]
x11-misc/xsel"
DEPEND="${RDEPEND}
- dev-ml/lablgl[glut,ocamlopt?]"
-BDEPEND="
>=dev-lang/ocaml-4.09[ocamlopt?]
- app-text/asciidoc
- virtual/pkgconfig"
+ dev-ml/lablgl[glut,ocamlopt?]"
RESTRICT="!ocamlopt? ( strip )"
@@ -55,16 +56,6 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" PREFIX="/usr" install
+ emake DESTDIR="${ED}" PREFIX="/usr" install
dodoc README Thanks
}
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}