summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-02 01:23:18 +0000
committerSam James <sam@gentoo.org>2024-02-02 01:23:18 +0000
commit0125f392b80ac586daa21e732af1c571b98b5ce5 (patch)
treea42b481006dc936c0745759badc7f471ca15bdf8 /app-text/libpaper
parentapp-emulation/vagrant: fix LICENSE (diff)
downloadgentoo-0125f392b80ac586daa21e732af1c571b98b5ce5.tar.gz
gentoo-0125f392b80ac586daa21e732af1c571b98b5ce5.tar.bz2
gentoo-0125f392b80ac586daa21e732af1c571b98b5ce5.zip
app-text/libpaper: add 2.1.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/libpaper')
-rw-r--r--app-text/libpaper/Manifest1
-rw-r--r--app-text/libpaper/libpaper-2.1.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-text/libpaper/Manifest b/app-text/libpaper/Manifest
index 2dbb42d83124..e8ed3c20daac 100644
--- a/app-text/libpaper/Manifest
+++ b/app-text/libpaper/Manifest
@@ -1,2 +1,3 @@
DIST libpaper-2.1.2.tar.gz 1264200 BLAKE2B d931c70ea1b26e57ef5cf120189dbf089d7b122ab195b154e6dc100845f63acd051195662d1b019a2f738ebe65047207b39609f4db0e748eaabc3868f3a2ccb0 SHA512 29c5d8074c10f6413b4eaf779153828e59b4b7353e6b380b37ed6cac04a92dc367da775a62e561b47064728f4173cb526d05a8abd80334ad229ee2a42039ac7b
+DIST libpaper-2.1.3.tar.gz 1263513 BLAKE2B 920fa9857cef5773a3570bd613152f09726cfeb8e07f8152460b37ee863b76ea28ef4c2d80d010e10368e952281e5138b1412c22e1cbfa27053bb3b6067bbcbf SHA512 7ebd469b7d6f22cd98e5811cf87403d066974dc2624d35653803c318258cb68506dc2abeb7129b03231aa32c36a7461275b20f4a43c51f0cd70b2db59a1a2988
DIST libpaper_1.1.28.tar.gz 42356 BLAKE2B 48c4a28c6ff01bd91e257b6b306e787e5c6112052cff09bdb501d1cc4ddd10964c3588942098a6092d5a44391dfb22e10d5147d4c5012497f473473129ff7422 SHA512 3bf6ebb0af89931d2f72ea4a09a7fa958b2facda5f238983ec7bac39652e08614b33f0de3af74a03457b2a4203eee4950bf18a4b726e79aa64093ace6a1fb0bc
diff --git a/app-text/libpaper/libpaper-2.1.3.ebuild b/app-text/libpaper/libpaper-2.1.3.ebuild
new file mode 100644
index 000000000000..06d8f269983b
--- /dev/null
+++ b/app-text/libpaper/libpaper-2.1.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Library for handling paper characteristics"
+HOMEPAGE="https://github.com/rrthomas/libpaper"
+SRC_URI="https://github.com/rrthomas/libpaper/releases/download/v${PV}/${P}.tar.gz"
+
+# See README.
+# paperspecs is public-domain
+LICENSE="LGPL-2.1+ GPL-3+ public-domain"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # Gnulib false positives #898346
+ # These are all tested without an #include first
+ MIN alignof static_assert
+)
+
+src_configure() {
+ econf --enable-relocatable
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}