summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-14 05:39:36 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-15 21:55:31 +0200
commitf58c0f6d0c3fac33eb1957ff908d65d2f74ca36a (patch)
treefc796806ae8a9caf450296d70c4c4801f5db4739 /app-text/htmldoc/htmldoc-1.8.29.ebuild
parentdev-perl/Test-Memory-Cycle: Bump to version 1.60.0 (diff)
downloadgentoo-f58c0f6d0c3fac33eb1957ff908d65d2f74ca36a.tar.gz
gentoo-f58c0f6d0c3fac33eb1957ff908d65d2f74ca36a.tar.bz2
gentoo-f58c0f6d0c3fac33eb1957ff908d65d2f74ca36a.zip
app-text/htmldoc: Bump to version 1.8.29
This bump includes 2 patches: - One to patch out the complete lack of DESTDIR support upstream - The other is to patch an annoying defect where failures in child Make targets result in "make" returning true, and the build finishing and installing in a broken state. Upstream have dropped SSL Support. This will hopefully resolve several bugs: - https://bugs.gentoo.org/572262 - Toralf - https://bugs.gentoo.org/549960 - Toralf - https://bugs.gentoo.org/527624 - Diego Thanks to Toralf Förster and Diego Elio Pettenò for reporting the bugs. Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
Diffstat (limited to 'app-text/htmldoc/htmldoc-1.8.29.ebuild')
-rw-r--r--app-text/htmldoc/htmldoc-1.8.29.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-text/htmldoc/htmldoc-1.8.29.ebuild b/app-text/htmldoc/htmldoc-1.8.29.ebuild
new file mode 100644
index 000000000000..db8e07548116
--- /dev/null
+++ b/app-text/htmldoc/htmldoc-1.8.29.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Convert HTML pages into a PDF document"
+SRC_URI="http://www.msweet.org/files/project1/${P}-source.tar.bz2"
+HOMEPAGE="http://www.msweet.org/projects.php?Z1"
+
+IUSE="fltk"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=media-libs/libpng-1.4:0=
+ virtual/jpeg:0
+ fltk? ( x11-libs/fltk:1 )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # make sure not to use the libs htmldoc ships with
+ mkdir foo ; mv jpeg foo/ ; mv png foo/ ; mv zlib foo/
+
+ sed -i "s:^#define DOCUMENTATION \"\$prefix/share/doc/htmldoc\":#define DOCUMENTATION \"\$prefix/share/doc/${PF}/html\":" \
+ configure || die
+
+ eapply "${FILESDIR}/${PN}-destdir.patch" \
+ "${FILESDIR}/${PN}-break.patch"
+
+ default
+}
+
+src_configure() {
+ local myconf="$(use_with fltk gui)"
+
+ econf ${myconf}
+ # Add missing -lfltk_images to LIBS
+ if use fltk; then
+ sed -i 's:-lfltk :-lfltk -lfltk_images :g' Makedefs || die
+ fi
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Minor cleanups
+ mv "${D}/usr/share/doc/htmldoc" "${D}/usr/share/doc/${PF}"
+ dodir /usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/doc/${PF}/*.html "${D}/usr/share/doc/${PF}/html"
+}