summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-06 01:04:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-06 03:22:42 +0100
commit7c8bcd877f6305d5429f70e572909d72df163e64 (patch)
tree34b6164e6722063b43991535cc1b4d4e56430081 /app-text/epstool
parentapp-text/epstool: Update HOMEPAGE (diff)
downloadgentoo-7c8bcd877f6305d5429f70e572909d72df163e64.tar.gz
gentoo-7c8bcd877f6305d5429f70e572909d72df163e64.tar.bz2
gentoo-7c8bcd877f6305d5429f70e572909d72df163e64.zip
app-text/epstool: 3.09 version bump, EAPI-7 bump
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/epstool')
-rw-r--r--app-text/epstool/Manifest1
-rw-r--r--app-text/epstool/epstool-3.09.ebuild42
-rw-r--r--app-text/epstool/files/epstool-3.09-no-gcc-linker.patch27
-rw-r--r--app-text/epstool/files/epstool-3.09-no-use-gnu.patch31
4 files changed, 101 insertions, 0 deletions
diff --git a/app-text/epstool/Manifest b/app-text/epstool/Manifest
index f3131c5f6cb6..519ecdd36aee 100644
--- a/app-text/epstool/Manifest
+++ b/app-text/epstool/Manifest
@@ -1 +1,2 @@
DIST epstool-3.08.tar.gz 191567 BLAKE2B 6ef2912e10e65809f60444d09facc1ea3800e492e55e87a4f00c95f7dbabd45c4d48b447fd92879e97e9dc2fe9698c1ff7d4cb06bdf3724f16ed89f76a829a8d SHA512 d6d70825c7d08cca318503bd8c12b48408b6d6cd3a64f26df94890373a3e73b68dc09a4eb454b81893c7ee3c11da791cdfed7466eb1410414cd1b97d80e8abf1
+DIST epstool-3.09.tar.gz 191023 BLAKE2B becb264bf93bdb1244550e0707eb2d513d8c4b8d9eee09356bd2ddaf25bc8b97e0c5e73a02839a0f66f18bd1949cb549525967ec430104c33067d9ca57984a6f SHA512 cb9519be0879ff791f0e243a541538254e24949683aa792f673334d2d1dbd3e449ec36890ccbb3852563cf8da997a035a80df605b395a1b84cbced7522dce291
diff --git a/app-text/epstool/epstool-3.09.ebuild b/app-text/epstool/epstool-3.09.ebuild
new file mode 100644
index 000000000000..80be2e478d44
--- /dev/null
+++ b/app-text/epstool/epstool-3.09.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Creates or extracts preview images in EPS files, fixes bounding boxes"
+HOMEPAGE="http://www.ghostgum.com.au/software/epstool.htm"
+SRC_URI="http://www.ghostgum.com.au/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="app-text/ghostscript-gpl"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-no-use-gnu.patch
+ "${FILESDIR}"/${P}-no-gcc-linker.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+
+ # parallel make issue (bug #506978)
+ mkdir bin || die
+ mkdir epsobj || die
+}
+
+src_compile() {
+ emake epstool
+}
+
+src_install() {
+ dobin bin/epstool
+ doman doc/epstool.1
+ local HTML_DOCS=( doc/epstool.htm doc/gsview.css )
+ einstalldocs
+}
diff --git a/app-text/epstool/files/epstool-3.09-no-gcc-linker.patch b/app-text/epstool/files/epstool-3.09-no-gcc-linker.patch
new file mode 100644
index 000000000000..cf3e03dfa609
--- /dev/null
+++ b/app-text/epstool/files/epstool-3.09-no-gcc-linker.patch
@@ -0,0 +1,27 @@
+From cbd73f2bb7dd3a55d0d35b0638e84b8f17e56b52 Mon Sep 17 00:00:00 2001
+From: Helmut Grohne <helmut@subdivi.de>
+Date: Fri, 14 Sep 2018 18:17:39 +0200
+Subject: [PATCH] Make epstool cross buildable by not hardcoding gcc as linker
+
+---
+ src/unixcom.mak | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/unixcom.mak b/src/unixcom.mak
+index 1063b65..ca0b031 100755
+--- a/src/unixcom.mak
++++ b/src/unixcom.mak
+@@ -22,8 +22,8 @@ GSCFLAGS= $(CDEFS) -Wall -Wstrict-prototypes -Wmissing-declarations -Wmissing-pr
+ CCAUX=gcc
+ CC=gcc
+ LFLAGS=$(PLINK) $(LIBPNGLIBS) $(GTKLIBS)
+-CLINK=gcc $(LDFLAGS)
+-LINK=gcc $(LDFLAGS)
++CLINK=$(CC) $(LDFLAGS)
++LINK=$(CC) $(LDFLAGS)
+
+
+ COMP=$(CC) -I$(SRCDIR) -I$(OBJDIR) $(CFLAGS) $(GSCFLAGS)
+--
+2.29.2
+
diff --git a/app-text/epstool/files/epstool-3.09-no-use-gnu.patch b/app-text/epstool/files/epstool-3.09-no-use-gnu.patch
new file mode 100644
index 000000000000..cb42381138e2
--- /dev/null
+++ b/app-text/epstool/files/epstool-3.09-no-use-gnu.patch
@@ -0,0 +1,31 @@
+From 706546a4921b98834ebf241ea751e0db5d0d192f Mon Sep 17 00:00:00 2001
+From: Adrian Bunk <bunk@debian.org>
+Date: Fri, 14 Sep 2018 18:17:39 +0200
+Subject: [PATCH] src/cplat.h: Don't define __USE_GNU
+
+There were two things wrong with it:
+- __USE_GNU is glibc-internal, the external define is _GNU_SOURCE
+- defining such macros after the first include is wrong, in this case
+it caused FTBFS on ia64.
+
+An option would be to pass -D_GNU_SOURCE when building, but as far
+as I can see the define was not (anymore?) needed at all.
+---
+ src/cplat.h | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/cplat.h b/src/cplat.h
+index 8bbd9c5..ad5cee4 100755
+--- a/src/cplat.h
++++ b/src/cplat.h
+@@ -109,7 +109,6 @@ typedef struct POINT_s {
+ typedef struct _GdkRgbCmap GdkRgbCmap;
+ # endif
+ # include <unistd.h>
+-# define __USE_GNU /* we might need recursive mutex */
+ # include <semaphore.h>
+ # include <pthread.h>
+ # define ZLIBNAME "libz.so"
+--
+2.29.2
+