summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/docbook2X
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/docbook2X')
-rw-r--r--app-text/docbook2X/Manifest1
-rw-r--r--app-text/docbook2X/docbook2X-0.8.8-r4.ebuild57
-rw-r--r--app-text/docbook2X/files/docbook2X-0.8.8-drop-htmldir.patch14
-rw-r--r--app-text/docbook2X/files/docbook2X-0.8.8-error_on_missing_refentry.patch33
-rw-r--r--app-text/docbook2X/files/docbook2X-0.8.8-filename_whitespace_handling.patch43
-rw-r--r--app-text/docbook2X/files/docbook2X-0.8.8-preprocessor_declaration_syntax.patch90
-rw-r--r--app-text/docbook2X/metadata.xml10
7 files changed, 248 insertions, 0 deletions
diff --git a/app-text/docbook2X/Manifest b/app-text/docbook2X/Manifest
new file mode 100644
index 000000000000..f15bd53973e3
--- /dev/null
+++ b/app-text/docbook2X/Manifest
@@ -0,0 +1 @@
+DIST docbook2X-0.8.8.tar.gz 723909 SHA256 4077757d367a9d1b1427e8d5dfc3c49d993e90deabc6df23d05cfe9cd2fcdc45 SHA512 cc336017ad734fc62d96d289105e8ea154c418a03a37f3e21b0b3520063f8b466b4aae5a5aec2e0b83f6324c6c79b5557247a93338d0a9882a94a44112f6b65c WHIRLPOOL 60cf325cbb9dbc7e0edc3a7bc4beb061259b22602efae54335f3828417c593ce7cb4c838eb33d598e1e6c2b2583e93eafbdfab37dba2873f1d8abaa72ed07b95
diff --git a/app-text/docbook2X/docbook2X-0.8.8-r4.ebuild b/app-text/docbook2X/docbook2X-0.8.8-r4.ebuild
new file mode 100644
index 000000000000..3bf236613527
--- /dev/null
+++ b/app-text/docbook2X/docbook2X-0.8.8-r4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1 #290284
+inherit autotools-utils
+
+DESCRIPTION="Tools to convert docbook to man and info"
+SRC_URI="mirror://sourceforge/docbook2x/${P}.tar.gz"
+HOMEPAGE="http://docbook2x.sourceforge.net/"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-linux ~x86-solaris"
+IUSE="test"
+LICENSE="MIT"
+
+# dev-perl/XML-LibXML - although not mentioned upstream is required
+# for make check to complete.
+DEPEND="dev-lang/perl
+ dev-libs/libxslt
+ dev-perl/XML-NamespaceSupport
+ dev-perl/XML-SAX
+ dev-perl/XML-LibXML
+ app-text/docbook-xsl-stylesheets
+ =app-text/docbook-xml-dtd-4.2*"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # Patches from debian, for description see patches itself.
+ "${FILESDIR}/${P}-filename_whitespace_handling.patch"
+ "${FILESDIR}/${P}-preprocessor_declaration_syntax.patch"
+ "${FILESDIR}/${P}-error_on_missing_refentry.patch"
+ # bug #296112
+ "${FILESDIR}/${P}-drop-htmldir.patch"
+)
+src_prepare() {
+ sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac || die 'sed on configure.ac failed'
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ --with-xslt-processor=libxslt
+ --program-transform-name='/^docbook2/s,$,.pl,'
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ dosym docbook2man.pl /usr/bin/docbook2x-man
+ dosym docbook2texi.pl /usr/bin/docbook2x-texi
+}
diff --git a/app-text/docbook2X/files/docbook2X-0.8.8-drop-htmldir.patch b/app-text/docbook2X/files/docbook2X-0.8.8-drop-htmldir.patch
new file mode 100644
index 000000000000..a7e11b2dfd7e
--- /dev/null
+++ b/app-text/docbook2X/files/docbook2X-0.8.8-drop-htmldir.patch
@@ -0,0 +1,14 @@
+Put HTML documentation in proper directory.
+Patch by Chris Mayo, https://bugs.gentoo.org/show_bug.cgi?id=296112
+
+--- doc/Makefile.am.orig
++++ doc/Makefile.am
+@@ -182,8 +182,6 @@
+ # Install (automake)
+ #
+
+-htmldir = $(datadir)/doc/docbook2X
+-
+ man_MANS = $(MAN_FILES)
+ html_DATA = $(HTML_FILES)
+ info_TEXINFOS = docbook2X.texi
diff --git a/app-text/docbook2X/files/docbook2X-0.8.8-error_on_missing_refentry.patch b/app-text/docbook2X/files/docbook2X-0.8.8-error_on_missing_refentry.patch
new file mode 100644
index 000000000000..b8a493be2f36
--- /dev/null
+++ b/app-text/docbook2X/files/docbook2X-0.8.8-error_on_missing_refentry.patch
@@ -0,0 +1,33 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 05_fix_439214_error_on_missing_refentry.dpatch by Daniel Leidert <daniel.leidert@wgdd.de>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: If there is no refentry element, the manpage stylesheets silently
+## DP: "ignores" this. It has been requested to print at least a
+## DP: warning.
+## DP:
+## DP: <URL:http://bugs.debian.org/439214>
+## DP: <URL:http://lists.gnu.org/archive/html/groff/2007-11/msg00023.html>
+
+@DPATCH@
+diff -urNad trunk~/xslt/man/docbook.xsl trunk/xslt/man/docbook.xsl
+--- trunk~/xslt/man/docbook.xsl 2006-04-11 21:00:19.000000000 +0200
++++ trunk/xslt/man/docbook.xsl 2008-02-05 03:31:48.000000000 +0100
+@@ -111,11 +111,15 @@
+ <xsl:when test="child::refentry">
+ <xsl:apply-templates />
+ </xsl:when>
+-
+- <xsl:otherwise>
++ <xsl:when test="descendant-or-self::refentry">
+ <manpageset>
+ <xsl:apply-templates select="descendant-or-self::refentry" />
+ </manpageset>
++ </xsl:when>
++ <xsl:otherwise>
++ <xsl:message terminate="no">
++ <xsl:text>WARNING: Sorry, but I cannot find a refentry element in your source!</xsl:text>
++ </xsl:message>
+ </xsl:otherwise>
+ </xsl:choose>
+ </xsl:template>
diff --git a/app-text/docbook2X/files/docbook2X-0.8.8-filename_whitespace_handling.patch b/app-text/docbook2X/files/docbook2X-0.8.8-filename_whitespace_handling.patch
new file mode 100644
index 000000000000..26cdf8e1baea
--- /dev/null
+++ b/app-text/docbook2X/files/docbook2X-0.8.8-filename_whitespace_handling.patch
@@ -0,0 +1,43 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 03_fix_420153_filename_whitespace_handling.dpatch by
+## Daniel Leidert (dale) <daniel.leidert@wgdd.de>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Peter Eisentraut reported a regression in the whitespace handling of
+## DP: refentrytitle content during filename creation:
+## DP: http://bugs.debian.org/420153. The problem is, that upstream first
+## DP: replaces all spaces (but not linebreaks btw) with underlines and then
+## DP: it tries to normalize the result. This means, that a linebreak with
+## DP: additional whitespaces results in manpage names like 'foo_ ____bar.9'.
+## DP: So what we basically do in this patch is, that we first normalize the
+## DP: refentrytitle and then replace any spaces left with underlines.
+
+@DPATCH@
+diff -urNad docbook2x-0.8.8~/xslt/man/manpage.xsl docbook2x-0.8.8/xslt/man/manpage.xsl
+--- docbook2x-0.8.8~/xslt/man/manpage.xsl 2006-04-20 15:45:55.000000000 +0200
++++ docbook2x-0.8.8/xslt/man/manpage.xsl 2007-04-20 16:19:28.000000000 +0200
+@@ -30,7 +30,7 @@
+
+ <xsl:template name="manpage-filename">
+ <xsl:param name="filename" />
+- <xsl:value-of select="normalize-space(translate($filename, &quot; /&quot;, &quot;__&quot;))" />
++ <xsl:value-of select="translate(normalize-space($filename), ' /', '__')" />
+ </xsl:template>
+
+
+diff -urNad docbook2x-0.8.8~/xslt/man/refentry.xsl docbook2x-0.8.8/xslt/man/refentry.xsl
+--- docbook2x-0.8.8~/xslt/man/refentry.xsl 2006-04-21 04:39:55.000000000 +0200
++++ docbook2x-0.8.8/xslt/man/refentry.xsl 2007-04-20 16:21:53.000000000 +0200
+@@ -38,7 +38,11 @@
+ <xsl:template name="refentry-filename">
+ <xsl:param name="title" />
+
+- <xsl:variable name="title2" select="translate($title, &quot; /&quot;, &quot;__&quot;)" />
++ <xsl:variable name="title2">
++ <xsl:call-template name="manpage-filename">
++ <xsl:with-param name="filename" select="$title" />
++ </xsl:call-template>
++ </xsl:variable>
+
+ <!-- not using gentext here since man page names tend not to have
+ accented chars / non-Latin chars ...
diff --git a/app-text/docbook2X/files/docbook2X-0.8.8-preprocessor_declaration_syntax.patch b/app-text/docbook2X/files/docbook2X-0.8.8-preprocessor_declaration_syntax.patch
new file mode 100644
index 000000000000..b6ddbfa2a0d3
--- /dev/null
+++ b/app-text/docbook2X/files/docbook2X-0.8.8-preprocessor_declaration_syntax.patch
@@ -0,0 +1,90 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 04_fix_442782_preprocessor_declaration_syntax.dpatch by Colin Watson <cjwatson@debian.org>.
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Conventionally, preprocessor declarations should start with
+## DP: '\"
+## DP: rather than
+## DP: .\"
+## DP: Current man-db only supports the first (and recommended) syntax. So
+## DP: Colin Watson provided this patch to fix docbook2x.
+## DP:
+## DP: <URL:http://bugs.debian.org/442782>
+## DP: <URL:http://lists.gnu.org/archive/html/groff/2007-11/msg00023.html>
+
+@DPATCH@
+diff -urNad trunk~/perl/db2x_manxml.pl trunk/perl/db2x_manxml.pl
+--- trunk~/perl/db2x_manxml.pl 2006-04-22 17:21:32.000000000 +0200
++++ trunk/perl/db2x_manxml.pl 2007-11-24 01:27:37.000000000 +0100
+@@ -342,6 +342,25 @@
+ $self->{line_start} = 1;
+ }
+
++#
++# Print a comment in the output, without causing a break.
++# Params: comment - the comment text.
++# May use any characters; they need not be escaped.
++#
++sub comment_nobreak
++{
++ my ($self, $comment) = @_;
++ $self->write("\n") unless $self->{line_start};
++
++ foreach my $line (split(/\n/, $comment)) {
++ $self->write('\'\" ');
++ $self->write($line);
++ $self->write("\n");
++ }
++
++ $self->{line_start} = 1;
++}
++
+
+ #
+ # Use a roff "escape" i.e. commands embedded in text starting with \
+@@ -510,16 +529,20 @@
+
+ $self->{'adjust-stack'} = [ 'b' ];
+
+- $self->{rw}->comment($elem->attr('preprocessors'))
+- if($elem->attr('preprocessors') ne '');
+-
++ my $preprocessors = $elem->attr('preprocessors');
+ # I've dug through the Internet to see if there was any
+ # standard way to specify encoding with man pages.
+ # The following seems to be a reasonable proposal:
+ # <URL:http://mail.nl.linux.org/linux-utf8/2001-04/msg00168.html>
+ my $encoding = $self->{options}->{'encoding'};
+ $encoding =~ s#//TRANSLIT$##i;
+- $self->{rw}->comment("-*- coding: $encoding -*-");
++ $encoding = "-*- coding: $encoding -*-";
++ if ($preprocessors eq '') {
++ $preprocessors = $encoding;
++ } else {
++ $preprocessors = "$preprocessors $encoding";
++ }
++ $self->{rw}->comment_nobreak($preprocessors);
+
+ # Define escapes for switching to and from monospace fonts (groff only)
+ $self->{rw}->request(qw{ .if \n(.g .ds T< \\\\FC});
+diff -urNad trunk~/xslt/backend/db2x_manxml.xsl trunk/xslt/backend/db2x_manxml.xsl
+--- trunk~/xslt/backend/db2x_manxml.xsl 2006-04-23 16:44:52.000000000 +0200
++++ trunk/xslt/backend/db2x_manxml.xsl 2007-11-24 01:27:37.000000000 +0100
+@@ -528,7 +528,7 @@
+ <exslt:document method="text"
+ encoding="{$encoding}"
+ href="{$path}">
+- <xsl:text>.\" -*- coding: </xsl:text>
++ <xsl:text>'\" -*- coding: </xsl:text>
+ <xsl:value-of select="$encoding" />
+ <xsl:text> -*-&#10;</xsl:text>
+ <xsl:copy-of select="$content" />
+@@ -538,7 +538,7 @@
+ <saxon:output method="text"
+ encoding="{$encoding}"
+ href="{$path}">
+- <xsl:text>.\" -*- coding: </xsl:text>
++ <xsl:text>'\" -*- coding: </xsl:text>
+ <xsl:value-of select="$encoding" />
+ <xsl:text> -*-&#10;</xsl:text>
+ <xsl:copy-of select="$content" />
diff --git a/app-text/docbook2X/metadata.xml b/app-text/docbook2X/metadata.xml
new file mode 100644
index 000000000000..2c3cc43124cc
--- /dev/null
+++ b/app-text/docbook2X/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">docbook2x</remote-id>
+ </upstream>
+</pkgmetadata>