summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-11-21 00:55:54 +0100
committerDavid Seifert <soap@gentoo.org>2022-11-21 00:55:54 +0100
commit9ac73bf83b7c5fbdeadab0ddb508b6c88a69461f (patch)
tree1f9dc3859e1b99d985b41a7d33f297fef3675018 /app-text/crf++
parentapp-text/gtkspell: update EAPI 6 -> 8 (diff)
downloadgentoo-9ac73bf83b7c5fbdeadab0ddb508b6c88a69461f.tar.gz
gentoo-9ac73bf83b7c5fbdeadab0ddb508b6c88a69461f.tar.bz2
gentoo-9ac73bf83b7c5fbdeadab0ddb508b6c88a69461f.zip
app-text/crf++: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-text/crf++')
-rw-r--r--app-text/crf++/crf++-0.58-r1.ebuild (renamed from app-text/crf++/crf++-0.58.ebuild)33
-rw-r--r--app-text/crf++/files/crf++-0.58-autotools.patch23
-rw-r--r--app-text/crf++/files/crf++-automake-1.13.patch10
3 files changed, 32 insertions, 34 deletions
diff --git a/app-text/crf++/crf++-0.58.ebuild b/app-text/crf++/crf++-0.58-r1.ebuild
index f14ffbc4defd..c10b4b472085 100644
--- a/app-text/crf++/crf++-0.58.ebuild
+++ b/app-text/crf++/crf++-0.58-r1.ebuild
@@ -1,59 +1,44 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
inherit autotools
-MY_P="${P^^[crf]}"
-
DESCRIPTION="Yet Another CRF toolkit for segmenting/labelling sequential data"
HOMEPAGE="https://taku910.github.io/crfpp/"
-SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
+SRC_URI="mirror://gentoo/${P^^}.tar.gz"
+S="${WORKDIR}/${P^^}"
LICENSE="|| ( BSD LGPL-2.1 )"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="examples static-libs"
+IUSE="examples"
-PATCHES=( "${FILESDIR}"/${PN}-automake-1.13.patch )
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
HTML_DOCS=( doc/. )
src_prepare() {
- sed -i \
- -e "/CFLAGS/s/-O3/${CFLAGS}/" \
- -e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
- configure.in
-
default
- mv configure.{in,ac} || die
eautoreconf
}
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
src_test() {
local d
for d in example/*; do
- cd "${d}"
+ pushd "${d}" >/dev/null || die
./exec.sh || die "failed test in ${d}"
- cd - >/dev/null
+ popd >/dev/null || die
done
}
src_install() {
- emake DESTDIR="${D}" install
- einstalldocs
+ default
if use examples; then
dodoc -r example
docompress -x /usr/share/doc/${PF}/example
fi
- if ! use static-libs; then
- find "${ED}" -name "*.la" -type f -delete || die
- fi
+ find "${ED}" -name '*.la' -type f -delete || die
}
diff --git a/app-text/crf++/files/crf++-0.58-autotools.patch b/app-text/crf++/files/crf++-0.58-autotools.patch
new file mode 100644
index 000000000000..df3584432bbe
--- /dev/null
+++ b/app-text/crf++/files/crf++-0.58-autotools.patch
@@ -0,0 +1,23 @@
+--- a/configure.in
++++ b/configure.in
+@@ -49,10 +49,8 @@
+ dnl
+ dnl check gcc
+ dnl
+-if test -n "$GCC"; then
+- CFLAGS="-O3 -Wall";
+- CXXFLAGS="-O3 -Wall";
+-fi
++CFLAGS="${CFLAGS} -Wall"
++CXXFLAGS="${CXXFLAGS} -Wall"
+
+ AC_DEFUN(ADD_CC_FLAG, [
+ AC_MSG_CHECKING(whether ${CC-cc} accepts $1)
+@@ -285,6 +283,6 @@
+ AC_MSG_RESULT([yes])
+
+ AC_SUBST(datarootdir)
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+ AC_OUTPUT([Makefile Makefile.msvc swig/version.h])
+
diff --git a/app-text/crf++/files/crf++-automake-1.13.patch b/app-text/crf++/files/crf++-automake-1.13.patch
deleted file mode 100644
index afff7edc0707..000000000000
--- a/app-text/crf++/files/crf++-automake-1.13.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/configure.in
-+++ b/configure.in
-@@ -240,6 +240,6 @@
- AC_MSG_RESULT([yes])
-
- AC_SUBST(datarootdir)
--AM_CONFIG_HEADER(config.h)
-+AC_CONFIG_HEADERS(config.h)
- AC_OUTPUT([Makefile Makefile.msvc swig/version.h])
-