summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-06 13:10:34 +0000
committerSam James <sam@gentoo.org>2022-12-06 14:54:43 +0000
commitfc6bc3500781216b38fa3e3ab44f5c0674f22793 (patch)
treeca758d37e3b9aab8fee64bf46014772afd4437d0 /app-text/aiksaurus
parentdev-python/nltk-data: link to upstream bug re LICENSE (diff)
downloadgentoo-fc6bc3500781216b38fa3e3ab44f5c0674f22793.tar.gz
gentoo-fc6bc3500781216b38fa3e3ab44f5c0674f22793.tar.bz2
gentoo-fc6bc3500781216b38fa3e3ab44f5c0674f22793.zip
app-text/aiksaurus: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/aiksaurus')
-rw-r--r--app-text/aiksaurus/aiksaurus-1.2.1-r3.ebuild (renamed from app-text/aiksaurus/aiksaurus-1.2.1-r2.ebuild)14
-rw-r--r--app-text/aiksaurus/files/aiksaurus-1.2.1-autoconf.patch13
-rw-r--r--app-text/aiksaurus/files/aiksaurus-1.2.1-format-security.patch29
-rw-r--r--app-text/aiksaurus/files/aiksaurus-1.2.1-gcc43.patch30
4 files changed, 22 insertions, 64 deletions
diff --git a/app-text/aiksaurus/aiksaurus-1.2.1-r2.ebuild b/app-text/aiksaurus/aiksaurus-1.2.1-r3.ebuild
index 1fbc912f1abb..968ec591c6f3 100644
--- a/app-text/aiksaurus/aiksaurus-1.2.1-r2.ebuild
+++ b/app-text/aiksaurus/aiksaurus-1.2.1-r3.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit flag-o-matic libtool
+inherit autotools flag-o-matic
-DESCRIPTION="A thesaurus lib, tool and database"
+DESCRIPTION="A thesaurus lib, tool, and database"
HOMEPAGE="https://sourceforge.net/projects/aiksaurus"
SRC_URI="
mirror://sourceforge/${PN}/${P}.tar.gz
@@ -24,13 +24,17 @@ PATCHES=(
"${WORKDIR}"/patches/${P}-gcc43.patch
"${WORKDIR}"/patches/${P}-format-security.patch
"${WORKDIR}"/patches/${P}-c++17.patch
+ "${FILESDIR}"/aiksaurus-1.2.1-autoconf.patch
)
src_prepare() {
default
+
# Needed to make relink work on FreeBSD, without it won't install.
# Also needed for a sane .so versionning there.
- elibtoolize
+ #elibtoolize
+ # Clang 16
+ eautoreconf
}
src_configure() {
diff --git a/app-text/aiksaurus/files/aiksaurus-1.2.1-autoconf.patch b/app-text/aiksaurus/files/aiksaurus-1.2.1-autoconf.patch
new file mode 100644
index 000000000000..2821709e7784
--- /dev/null
+++ b/app-text/aiksaurus/files/aiksaurus-1.2.1-autoconf.patch
@@ -0,0 +1,13 @@
+https://sources.debian.org/patches/aiksaurus/1.2.1%2Bdev-0.12-7/01-changes-from-pristine-tarball.patch/
+--- a/configure.ac
++++ b/configure.ac
+@@ -50,6 +50,9 @@ AC_SUBST(LT_RELEASE)
+ LT_CURRENT=`expr $AIK_MICRO_VERSION - $AIK_INTERFACE_AGE`
+ LT_REVISION=$AIK_INTERFACE_AGE
+ LT_AGE=`expr $AIK_BINARY_AGE - $AIK_INTERFACE_AGE`
++m4_pattern_allow([LT_CURRENT])
++m4_pattern_allow([LT_REVISION])
++m4_pattern_allow([LT_AGE])
+
+ LT_AIK_VERSION_INFO="$LT_CURRENT:$LT_REVISION:$LT_AGE"
+
diff --git a/app-text/aiksaurus/files/aiksaurus-1.2.1-format-security.patch b/app-text/aiksaurus/files/aiksaurus-1.2.1-format-security.patch
deleted file mode 100644
index ba90a4519502..000000000000
--- a/app-text/aiksaurus/files/aiksaurus-1.2.1-format-security.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- aiksaurus-1.2.1/base/caiksaurus.cpp.orig 2014-06-07 21:14:03.869649696 +0100
-+++ aiksaurus-1.2.1/base/caiksaurus.cpp 2014-06-07 21:33:06.241471066 +0100
-@@ -254,7 +254,7 @@
- /* see if we got --version. */
- if ( !strcmp(arg, "--version") || !strcmp(arg, "-v") )
- {
-- printf(version);
-+ printf("%s", version);
- exit(0);
- }
-
-@@ -262,7 +262,7 @@
- else if ( !strcmp(arg, "--help") || !strcmp(arg, "-h") )
- {
- printf("Usage: %s [word]\n\n", argv[0]);
-- printf(help);
-+ printf("%s", help);
- exit(0);
- }
- }
-@@ -271,7 +271,7 @@
- if (argc != 2)
- {
- printf("Usage: %s [word]\n", argv[0]);
-- printf(help);
-+ printf("%s", help);
- exit(1);
- }
- }
diff --git a/app-text/aiksaurus/files/aiksaurus-1.2.1-gcc43.patch b/app-text/aiksaurus/files/aiksaurus-1.2.1-gcc43.patch
deleted file mode 100644
index a6d570af569d..000000000000
--- a/app-text/aiksaurus/files/aiksaurus-1.2.1-gcc43.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- aiksaurus-1.2.1/base/aiksaurus.t.cpp
-+++ aiksaurus-1.2.1/base/aiksaurus.t.cpp
-@@ -24,6 +24,7 @@
- #include "config.h"
- #include <iostream>
- #include <string>
-+#include <cstdlib>
- using namespace std;
- using AiksaurusImpl::AsciiCompare;
-
---- aiksaurus-1.2.1/gtk/src/Display.cpp
-+++ aiksaurus-1.2.1/gtk/src/Display.cpp
-@@ -22,6 +22,7 @@
- #include "Meaning.h"
- #include "DialogMediator.h"
- #include "Exception.h"
-+#include <cstring>
- using namespace std;
-
- namespace AiksaurusGTK_impl
---- aiksaurus-1.2.1/gtk/src/gtkAiksaur.t.cpp
-+++ aiksaurus-1.2.1/gtk/src/gtkAiksaur.t.cpp
-@@ -23,6 +23,7 @@
- #include <gtk/gtk.h>
- #include <iostream>
- #include <string>
-+#include <cstdlib>
- using namespace std;
-
- int main(int argc, char** argv)