summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2023-02-26 22:38:09 +0900
committerAkinori Hattori <hattya@gentoo.org>2023-02-26 22:38:09 +0900
commit2d804f4b3e994d81cf6a80916cd3465200612ccc (patch)
treede7d6301da0362f2117395ae77647b6b97095d90 /app-shells
parentapp-i18n/ibus-table-others: new upstream release (diff)
downloadgentoo-2d804f4b3e994d81cf6a80916cd3465200612ccc.tar.gz
gentoo-2d804f4b3e994d81cf6a80916cd3465200612ccc.tar.bz2
gentoo-2d804f4b3e994d81cf6a80916cd3465200612ccc.zip
app-shells/yash: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/yash/Manifest1
-rw-r--r--app-shells/yash/yash-2.54.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/yash/Manifest b/app-shells/yash/Manifest
index dd1caf4451c6..a01ef666b3cd 100644
--- a/app-shells/yash/Manifest
+++ b/app-shells/yash/Manifest
@@ -1 +1,2 @@
DIST yash-2.53.tar.xz 755956 BLAKE2B 191bdc6fcda7c3043d3db53b70fcdba86fab740df2aaf1249380c4679f51ec61b9a36c51a7982c516f51f8a2605729d7242d81f738523edfc07f21be1a06ff45 SHA512 9bc6dcc9864fbba6200b76dad50b9eb1620b578fceaea5d1dd34e2efda379be0e4255d56e49c9595dc184ddf45951418e87a88dc6507d41cc4220f38b7044994
+DIST yash-2.54.tar.xz 758916 BLAKE2B 902bb06fa70be4980ea2a9def3cc910ff33d51350a37c5ec5a12fe7282a8e41e5a4a55bc45f66d3dd45b33cacc9af46110dc37c37d2978f686c3a1a7a8fd23b5 SHA512 360dc55782def4ce8c1a5cf12836ec86405dfbe338c6a623c8031e84f76da1bfa2e5a5ad05c1a62ea7b516681457d124398e2194e2d23824c19216eb3807e155
diff --git a/app-shells/yash/yash-2.54.ebuild b/app-shells/yash/yash-2.54.ebuild
new file mode 100644
index 000000000000..c520a04f1b52
--- /dev/null
+++ b/app-shells/yash/yash-2.54.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PLOCALES="en ja"
+
+inherit flag-o-matic plocale toolchain-funcs
+
+DESCRIPTION="Yash is a POSIX-compliant command line shell"
+HOMEPAGE="https://yash.osdn.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/78345/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-libs/ncurses:=
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ append-cflags -std=c99
+
+ sh ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --exec-prefix="${EPREFIX}" \
+ $(use_enable nls) \
+ CC="$(tc-getCC)" \
+ LINGUAS="$(plocale_get_locales | sed "s/en/en@quot en@boldquot/")" \
+ || die
+}