summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMattéo Rossillol‑‑Laruelle <beatussum@protonmail.com>2024-05-27 12:24:23 +0200
committerViorel Munteanu <ceamac@gentoo.org>2024-05-27 14:52:41 +0300
commit40a2da4521399bf21a7b5e380f31ed6e04504285 (patch)
tree8fed33eceb30ac673a0ca762198149616e1ec9e8 /app-shells/zsh-syntax-highlighting
parentwww-client/chromium: drop 126.0.6478.8 (diff)
downloadgentoo-40a2da4521399bf21a7b5e380f31ed6e04504285.tar.gz
gentoo-40a2da4521399bf21a7b5e380f31ed6e04504285.tar.bz2
gentoo-40a2da4521399bf21a7b5e380f31ed6e04504285.zip
app-shells/zsh-syntax-highlighting: add 0.8.0 and adoption
Closes: https://bugs.gentoo.org/920942 Signed-off-by: Mattéo Rossillol‑‑Laruelle <beatussum@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/36175 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-shells/zsh-syntax-highlighting')
-rw-r--r--app-shells/zsh-syntax-highlighting/Manifest1
-rw-r--r--app-shells/zsh-syntax-highlighting/metadata.xml15
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.8.0.ebuild48
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-9999.ebuild48
4 files changed, 111 insertions, 1 deletions
diff --git a/app-shells/zsh-syntax-highlighting/Manifest b/app-shells/zsh-syntax-highlighting/Manifest
index 6a76ff54d77e..c64266de01fa 100644
--- a/app-shells/zsh-syntax-highlighting/Manifest
+++ b/app-shells/zsh-syntax-highlighting/Manifest
@@ -1 +1,2 @@
DIST zsh-syntax-highlighting-0.7.1.tar.gz 133554 BLAKE2B cd55a0ad69670b25edc4bfa78ad76d1e2ef501deeca3e93adbef0aca305896722b4906d7717be3ad61bc0cf6b6496e217626406e5ff4168ece4b75bffd94bbf0 SHA512 e7e86b88cdac9b9ed5f973823ba8efff99dd720b9ed929f765f9f9266b9d6e147274f5957ceb630d51a660e396fc22e97f10cfbc5cdde941b907f3773bb1ea2b
+DIST zsh-syntax-highlighting-0.8.0.tar.gz 155914 BLAKE2B bdb95dc825514e2c0ced2a33133967089fdbd851e00874f68497cd5daae2010f5335fb173569f5af6aea65f4e23744076c420ebc957b7bdba325fcec573d3805 SHA512 58593c8bf3fa1476ecf0fceb1fc4eab986a778de657d359a28fe48798e787896fbf2588441c69b017a08227ab44dd46473afb16e0f125aae59cc58004bfa8c2e
diff --git a/app-shells/zsh-syntax-highlighting/metadata.xml b/app-shells/zsh-syntax-highlighting/metadata.xml
index de67513b1cdd..9d74da2c04d0 100644
--- a/app-shells/zsh-syntax-highlighting/metadata.xml
+++ b/app-shells/zsh-syntax-highlighting/metadata.xml
@@ -1,9 +1,22 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>beatussum@protonmail.com</email>
+ <name>Mattéo Rossillol‑‑Laruelle</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<stabilize-allarches/>
<upstream>
+ <maintainer status="active">
+ <name>zsh-users</name>
+ </maintainer>
+
+ <changelog>https://raw.githubusercontent.com/zsh-users/zsh-syntax-highlighting/master/changelog.md</changelog>
+ <bugs-to>https://github.com/zsh-users/zsh-syntax-highlighting/issues</bugs-to>
<remote-id type="github">zsh-users/zsh-syntax-highlighting</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.8.0.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.8.0.ebuild
new file mode 100644
index 000000000000..0b1f5c2efd49
--- /dev/null
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.8.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+if [[ "${PV}" = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zsh-users/${PN}.git"
+else
+ SRC_URI="https://github.com/zsh-users/zsh-syntax-highlighting/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Fish shell like syntax highlighting for zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+DISABLE_AUTOFORMATTING="true"
+
+DOC_CONTENTS="\
+In order to use ${CATEGORY}/${PN}, add
+\`source /usr/share/zsh/site-functions/zsh-syntax-highlighting.zsh\`
+at the end of your ~/.zshrc"
+
+src_prepare() {
+ default
+
+ sed -i "s/COPYING.md//" Makefile || die
+}
+
+src_install() {
+ emake \
+ SHARE_DIR="${ED}/usr/share/zsh/site-functions" \
+ DOC_DIR="${ED}/usr/share/doc/${PF}" \
+ install
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-9999.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-9999.ebuild
new file mode 100644
index 000000000000..0b1f5c2efd49
--- /dev/null
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+if [[ "${PV}" = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zsh-users/${PN}.git"
+else
+ SRC_URI="https://github.com/zsh-users/zsh-syntax-highlighting/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Fish shell like syntax highlighting for zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting"
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-shells/zsh"
+
+DISABLE_AUTOFORMATTING="true"
+
+DOC_CONTENTS="\
+In order to use ${CATEGORY}/${PN}, add
+\`source /usr/share/zsh/site-functions/zsh-syntax-highlighting.zsh\`
+at the end of your ~/.zshrc"
+
+src_prepare() {
+ default
+
+ sed -i "s/COPYING.md//" Makefile || die
+}
+
+src_install() {
+ emake \
+ SHARE_DIR="${ED}/usr/share/zsh/site-functions" \
+ DOC_DIR="${ED}/usr/share/doc/${PF}" \
+ install
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}