summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-shells/mpibash
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-shells/mpibash')
-rw-r--r--app-shells/mpibash/Manifest1
-rw-r--r--app-shells/mpibash/metadata.xml12
-rw-r--r--app-shells/mpibash/mpibash-1.2.ebuild43
-rw-r--r--app-shells/mpibash/mpibash-9999.ebuild43
4 files changed, 99 insertions, 0 deletions
diff --git a/app-shells/mpibash/Manifest b/app-shells/mpibash/Manifest
new file mode 100644
index 000000000000..4d8ea88158d7
--- /dev/null
+++ b/app-shells/mpibash/Manifest
@@ -0,0 +1 @@
+DIST mpibash-1.2.tar.gz 347083 SHA256 5c2faaa74464111205dbae4799bd89c2425810ec3708d004237b42d620c8be57 SHA512 db755dd2c6212a8d7dfd6cbff17d5dffcbc3b6a0286abdad4d2e21790453d2356e88c566abe4648da138d6964098fad581b8fd5beae1335f5787de92f4659104 WHIRLPOOL 94fcf50d89250a6478a2ed56a0c1769dd678869884e1e80066ebdb479dd0c6d64048ade7829020fdad050b1e77a2315ab7e325a97aa472291d3e9a4888c915e3
diff --git a/app-shells/mpibash/metadata.xml b/app-shells/mpibash/metadata.xml
new file mode 100644
index 000000000000..519354940f17
--- /dev/null
+++ b/app-shells/mpibash/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">losalamos/MPI-Bash</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/mpibash/mpibash-1.2.ebuild b/app-shells/mpibash/mpibash-1.2.ebuild
new file mode 100644
index 000000000000..c36ec39e71c9
--- /dev/null
+++ b/app-shells/mpibash/mpibash-1.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="git://github.com/losalamos/MPI-Bash.git http://github.com/losalamos/MPI-Bash.git"
+ inherit git-r3
+ KEYWORDS=""
+ AUTOTOOLS_AUTORECONF=1
+else
+ SRC_URI="https://github.com/losalamos/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Parallel scripting right from the Bourne-Again Shell (Bash)"
+HOMEPAGE="https://github.com/losalamos/MPI-Bash"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="virtual/mpi
+ >=app-shells/bash-4.2[plugins]
+ sys-cluster/libcircle"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --with-bashdir="${EPREFIX}"/usr/include/bash-plugins
+ --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
+ use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
+}
diff --git a/app-shells/mpibash/mpibash-9999.ebuild b/app-shells/mpibash/mpibash-9999.ebuild
new file mode 100644
index 000000000000..c36ec39e71c9
--- /dev/null
+++ b/app-shells/mpibash/mpibash-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="git://github.com/losalamos/MPI-Bash.git http://github.com/losalamos/MPI-Bash.git"
+ inherit git-r3
+ KEYWORDS=""
+ AUTOTOOLS_AUTORECONF=1
+else
+ SRC_URI="https://github.com/losalamos/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Parallel scripting right from the Bourne-Again Shell (Bash)"
+HOMEPAGE="https://github.com/losalamos/MPI-Bash"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="virtual/mpi
+ >=app-shells/bash-4.2[plugins]
+ sys-cluster/libcircle"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --with-bashdir="${EPREFIX}"/usr/include/bash-plugins
+ --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
+ use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
+}