summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-09 19:11:48 +0000
committerSam James <sam@gentoo.org>2022-05-09 19:12:21 +0000
commite04ddc64562f2226e344ddb8fa4307340efb2b46 (patch)
tree293cdb751e5f4fd57c4b9e2d321c31c3c7be15fc /app-office
parentdev-util/maxcso: Use tc-getPKG_CONFIG (diff)
downloadgentoo-e04ddc64562f2226e344ddb8fa4307340efb2b46.tar.gz
gentoo-e04ddc64562f2226e344ddb8fa4307340efb2b46.tar.bz2
gentoo-e04ddc64562f2226e344ddb8fa4307340efb2b46.zip
app-office/libreoffice: slight tweak to Poppler 22.04.0 patch
Bug: https://bugs.gentoo.org/843311 Thanks-to: Stephan Hartmann <sultan@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/files/libreoffice-7.3.3.2-Add-missing-nSize-set-for-Poppler-22.04.0.patch16
-rw-r--r--app-office/libreoffice/libreoffice-7.3.3.2-r1.ebuild (renamed from app-office/libreoffice/libreoffice-7.3.3.2.ebuild)2
2 files changed, 12 insertions, 6 deletions
diff --git a/app-office/libreoffice/files/libreoffice-7.3.3.2-Add-missing-nSize-set-for-Poppler-22.04.0.patch b/app-office/libreoffice/files/libreoffice-7.3.3.2-Add-missing-nSize-set-for-Poppler-22.04.0.patch
index f273d9565051..22de747e01e4 100644
--- a/app-office/libreoffice/files/libreoffice-7.3.3.2-Add-missing-nSize-set-for-Poppler-22.04.0.patch
+++ b/app-office/libreoffice/files/libreoffice-7.3.3.2-Add-missing-nSize-set-for-Poppler-22.04.0.patch
@@ -2,24 +2,30 @@ https://bugs.gentoo.org/843311
From: Sam James <sam@gentoo.org>
Date: Sun, 8 May 2022 21:22:49 +0000
-Subject: [PATCH 2/2] Add missing nSize set for Poppler 22.04.0
+Subject: [PATCH] Add missing nSize set for Poppler 22.04.0
Thanks-to: Stephan Hartmann <sultan@gentoo.org>
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
-@@ -478,6 +478,7 @@ int PDFOutDev::parseFont( long long nNewId, GfxFont* gfxFont, const GfxState* st
+@@ -478,6 +478,10 @@ int PDFOutDev::parseFont( long long nNewId, GfxFont* gfxFont, const GfxState* st
char* pBuf = gfxFont->readEmbFontFile( m_pDoc->getXRef(), &nSize );
#else
std::optional<std::vector<unsigned char>> pBuf = gfxFont->readEmbFontFile( m_pDoc->getXRef() );
-+ nSize = pBuf->size();
++ if( pBuf )
++ {
++ nSize = pBuf->size();
++ }
#endif
if( pBuf )
{
-@@ -502,6 +503,7 @@ void PDFOutDev::writeFontFile( GfxFont* gfxFont ) const
+@@ -502,6 +506,10 @@ void PDFOutDev::writeFontFile( GfxFont* gfxFont ) const
char* pBuf = gfxFont->readEmbFontFile( m_pDoc->getXRef(), &nSize );
#else
std::optional<std::vector<unsigned char>> pBuf = gfxFont->readEmbFontFile( m_pDoc->getXRef() );
-+ nSize = pBuf->size();
++ if( pBuf )
++ {
++ nSize = pBuf->size();
++ }
#endif
if( !pBuf )
return;
diff --git a/app-office/libreoffice/libreoffice-7.3.3.2.ebuild b/app-office/libreoffice/libreoffice-7.3.3.2-r1.ebuild
index f229dff9382b..129fac1b9644 100644
--- a/app-office/libreoffice/libreoffice-7.3.3.2.ebuild
+++ b/app-office/libreoffice/libreoffice-7.3.3.2-r1.ebuild
@@ -302,7 +302,7 @@ PATCHES=(
# TODO: upstream
"${FILESDIR}/${PN}-7.2.6.2-poppler-22.03.0.patch" # by Archlinux
"${FILESDIR}/${PN}-7.3.3.2-Import-FreeBSD-patch-for-Poppler-22.04.0-build.patch" # from FreeBSD
- "${FILESDIR}/${PN}-7.3.3.2-Add-missing-nSize-set-for-Poppler-22.04.0.patch" # fixup for FreeBSD patch
+ #"${FILESDIR}/${PN}-7.3.3.2-Add-missing-nSize-set-for-Poppler-22.04.0.patch" # fixup for FreeBSD patch
)
S="${WORKDIR}/${PN}-${MY_PV}"