summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-10 11:45:41 +0100
committerSam James <sam@gentoo.org>2022-04-10 11:46:43 +0100
commita7aafd030a86bbbad39e1ccb7c86976cbe54a7e0 (patch)
tree01db47ff7122381106f3b8e46a1d976b43df545d /app-office
parentapp-office/libreoffice: add LLVM 14 to 7.3+; sync live (diff)
downloadgentoo-a7aafd030a86bbbad39e1ccb7c86976cbe54a7e0.tar.gz
gentoo-a7aafd030a86bbbad39e1ccb7c86976cbe54a7e0.tar.bz2
gentoo-a7aafd030a86bbbad39e1ccb7c86976cbe54a7e0.zip
app-office/libreoffice: fix jdk-home typo
Closes: https://bugs.gentoo.org/837587 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/libreoffice-7.3.2.2.ebuild4
-rw-r--r--app-office/libreoffice/libreoffice-7.3.9999.ebuild4
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/app-office/libreoffice/libreoffice-7.3.2.2.ebuild b/app-office/libreoffice/libreoffice-7.3.2.2.ebuild
index 9f5a7ab0de81..a516928958fc 100644
--- a/app-office/libreoffice/libreoffice-7.3.2.2.ebuild
+++ b/app-office/libreoffice/libreoffice-7.3.2.2.ebuild
@@ -570,9 +570,9 @@ src_configure() {
--with-ant-home="${ANT_HOME}"
)
if has_version "dev-java/openjdk:11"; then
- myeconfargs+=( -with-jdk-home="${EPREFIX}/usr/$(get_libdir)/openjdk-11" )
+ myeconfargs+=( --with-jdk-home="${EPREFIX}/usr/$(get_libdir)/openjdk-11" )
elif has_version "dev-java/openjdk-bin:11"; then
- myeconfargs+=( --with-jdk-home="/opt/openjdk-bin-11" )
+ myeconfargs+=( --with-jdk-home="${EPREFIX}/opt/openjdk-bin-11" )
fi
use libreoffice_extensions_scripting-beanshell && \
diff --git a/app-office/libreoffice/libreoffice-7.3.9999.ebuild b/app-office/libreoffice/libreoffice-7.3.9999.ebuild
index 0f7170a5e44e..6b265eb5bf1e 100644
--- a/app-office/libreoffice/libreoffice-7.3.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-7.3.9999.ebuild
@@ -567,9 +567,9 @@ src_configure() {
--with-ant-home="${ANT_HOME}"
)
if has_version "dev-java/openjdk:11"; then
- myeconfargs+=( -with-jdk-home="${EPREFIX}/usr/$(get_libdir)/openjdk-11" )
+ myeconfargs+=( --with-jdk-home="${EPREFIX}/usr/$(get_libdir)/openjdk-11" )
elif has_version "dev-java/openjdk-bin:11"; then
- myeconfargs+=( --with-jdk-home="/opt/openjdk-bin-11" )
+ myeconfargs+=( --with-jdk-home="${EPREFIX}/opt/openjdk-bin-11" )
fi
use libreoffice_extensions_scripting-beanshell && \
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index a30d4d21bfbd..73154bc2f905 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -567,9 +567,9 @@ src_configure() {
--with-ant-home="${ANT_HOME}"
)
if has_version "dev-java/openjdk:11"; then
- myeconfargs+=( -with-jdk-home="${EPREFIX}/usr/$(get_libdir)/openjdk-11" )
+ myeconfargs+=( --with-jdk-home="${EPREFIX}/usr/$(get_libdir)/openjdk-11" )
elif has_version "dev-java/openjdk-bin:11"; then
- myeconfargs+=( --with-jdk-home="/opt/openjdk-bin-11" )
+ myeconfargs+=( --with-jdk-home="${EPREFIX}/opt/openjdk-bin-11" )
fi
use libreoffice_extensions_scripting-beanshell && \