summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-04-22 15:32:08 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-04-22 15:35:19 +0200
commit591c90d4a4afd60e49e7b89ef42da60a0ce0de58 (patch)
tree2d1ea6fe174f3a7fff18fe7565b2e350bbf0dc4a /app-office
parentdev-embedded/openocd: drop 0.11.0 (diff)
downloadgentoo-591c90d4a4afd60e49e7b89ef42da60a0ce0de58.tar.gz
gentoo-591c90d4a4afd60e49e7b89ef42da60a0ce0de58.tar.bz2
gentoo-591c90d4a4afd60e49e7b89ef42da60a0ce0de58.zip
app-office/calligra: USE cmake FindGSL module instead of bundled one
Fixes potential build issues. Upstream commit fb545574a3e3b48b937dc4f741048c7033735e04, readjusted on top of our modifications. Closes: https://bugs.gentoo.org/903343 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/calligra/calligra-3.2.1-r7.ebuild2
-rw-r--r--app-office/calligra/files/calligra-3.2.1-use-cmake-FindGSL-module.patch29
2 files changed, 31 insertions, 0 deletions
diff --git a/app-office/calligra/calligra-3.2.1-r7.ebuild b/app-office/calligra/calligra-3.2.1-r7.ebuild
index f2e157c7c232..27b0ebbf1634 100644
--- a/app-office/calligra/calligra-3.2.1-r7.ebuild
+++ b/app-office/calligra/calligra-3.2.1-r7.ebuild
@@ -4,6 +4,7 @@
EAPI=8
CHECKREQS_DISK_BUILD="4G"
+CMAKE_REMOVE_MODULES_LIST=( FindGSL )
ECM_HANDBOOK="forceoptional"
ECM_TEST="forceoptional"
KFMIN=5.88.0
@@ -124,6 +125,7 @@ PATCHES=(
"${WORKDIR}"/${PATCHSET}/${P}-poppler-22.04.0.patch
"${WORKDIR}"/${PATCHSET}/${P}-clang-16-c++17.patch
"${WORKDIR}"/${PATCHSET}/${P}-kross-optional.patch # bug 903532
+ "${FILESDIR}"/${P}-use-cmake-FindGSL-module.patch # bug 903343
)
pkg_pretend() {
diff --git a/app-office/calligra/files/calligra-3.2.1-use-cmake-FindGSL-module.patch b/app-office/calligra/files/calligra-3.2.1-use-cmake-FindGSL-module.patch
new file mode 100644
index 000000000000..07e31a0ed77d
--- /dev/null
+++ b/app-office/calligra/files/calligra-3.2.1-use-cmake-FindGSL-module.patch
@@ -0,0 +1,29 @@
+From fb545574a3e3b48b937dc4f741048c7033735e04 Mon Sep 17 00:00:00 2001
+From: Dan Leinir Turthra Jensen <admin@leinir.dk>
+Date: Thu, 29 Apr 2021 13:02:39 +0100
+Subject: [PATCH] Fix GSL find module
+
+This increases the CMake requirement to 3.2 so we can use the GSL find
+module that ships with CMake since then. The custom find module
+apparently doesn't work right on Windows, so...
+---
+ sheets/plugins/solver/CMakeLists.txt | 4 +-
+ 1 filee changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/sheets/plugins/solver/CMakeLists.txt b/sheets/plugins/solver/CMakeLists.txt
+index 41bc4a77ae9..ecd4bd8d218 100644
+--- a/sheets/plugins/solver/CMakeLists.txt
++++ b/sheets/plugins/solver/CMakeLists.txt
+@@ -25,8 +25,8 @@ calligrasheets_viewplugin_desktop_to_json(sheetssolver sheetssolver.desktop)
+
+
+ target_link_libraries( sheetssolver
+- ${GSL_LIBRARIES}
+- ${GSL_CBLAS_LIBRARIES}
++ GSL::gsl
++ GSL::gslcblas
+ calligrasheetscommon
+ )
+
+--
+GitLab