summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-07-31 11:45:53 +0200
committerPacho Ramos <pacho@gentoo.org>2023-07-31 11:46:19 +0200
commite445b72370c33a0ed0657b8cea29d2500bfd40c0 (patch)
tree00ca9218e16539c392a0d797701239390867750b /app-office/onlyoffice-bin
parentdev-python/sphinx-prompt: Bump to 1.7.0 (diff)
downloadgentoo-e445b72370c33a0ed0657b8cea29d2500bfd40c0.tar.gz
gentoo-e445b72370c33a0ed0657b8cea29d2500bfd40c0.tar.bz2
gentoo-e445b72370c33a0ed0657b8cea29d2500bfd40c0.zip
app-office/onlyoffice-bin: add 7.4.1
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-office/onlyoffice-bin')
-rw-r--r--app-office/onlyoffice-bin/Manifest1
-rw-r--r--app-office/onlyoffice-bin/onlyoffice-bin-7.4.1.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/app-office/onlyoffice-bin/Manifest b/app-office/onlyoffice-bin/Manifest
index 72b336ea54b3..f22d3c86d1dc 100644
--- a/app-office/onlyoffice-bin/Manifest
+++ b/app-office/onlyoffice-bin/Manifest
@@ -1,2 +1,3 @@
DIST onlyoffice-bin-7.3.3_amd64.deb 194296022 BLAKE2B 3f687cd4cfffb742ea078d08b575f3893765f4a82003a52e8645917e3e5f164ed7d547458ee58621dc3cb021bf5bbcc7fa9e88ae5130afac9662c186b256ff1f SHA512 fd3e9a48e488ef8fb8be01f3b1bfeeb87fe1a25d2a81e1716146557cfdf8a3822d36f5a66f43c6cb596d8e072bc1d3407f8320b092d9a1f0e9a54bb9f7920fa8
DIST onlyoffice-bin-7.4.0_amd64.deb 201997240 BLAKE2B 70a97225f230e84e3dc33a7b94970a2ff93d6140b3e50e4533c2d92b592e956c4f7da65dc80f5414d0d8f75211bc08abe15ea35f8f961052c501619811381131 SHA512 ef1546d3b5b8d4257cb8c22e8a204590663f5e61a8e65f82bf410521b8e9ca13bb6999d13a9c1de241f6a8f8787ab9dfef7f3a2fe061b625b68014937324cd81
+DIST onlyoffice-bin-7.4.1_amd64.deb 202066536 BLAKE2B eb617fadb0bbffcff80d45cfe19e58a163af50d748f183ac09ae5799164bc5c20567c6e8961cfe6e151041df3ce090dd8de9de67b24e9081755cd92363ecfcc3 SHA512 8676d791ad9e32115837ffa060b208072d47b70b001abb2cbaa4fe1ff15265895756ca2bd2ae571b2f03e3af7d923534e5f3bc65f96a7a56052719e8156b6025
diff --git a/app-office/onlyoffice-bin/onlyoffice-bin-7.4.1.ebuild b/app-office/onlyoffice-bin/onlyoffice-bin-7.4.1.ebuild
new file mode 100644
index 000000000000..e88bb3d1c410
--- /dev/null
+++ b/app-office/onlyoffice-bin/onlyoffice-bin-7.4.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker xdg
+
+MY_P="ONLYOFFICE-DesktopEditors-"${PV}""
+
+DESCRIPTION="Onlyoffice is an office productivity suite (binary version)"
+HOMEPAGE="https://www.onlyoffice.com/"
+SRC_URI="
+ amd64? (
+ https://github.com/ONLYOFFICE/DesktopEditors/releases/download/v"${PV}"/onlyoffice-desktopeditors_amd64.deb
+ -> "${P}"_amd64.deb
+ )
+"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror strip test"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ dev-libs/wayland
+ dev-qt/qtgui:5[eglfs]
+ dev-qt/qtdeclarative:5
+ dev-qt/qtwayland:5
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/gst-plugins-base:1.0
+ media-libs/gstreamer:1.0
+ media-libs/harfbuzz
+ media-libs/libglvnd
+ media-libs/libpulse
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ x11-libs/pango
+"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="*"
+
+src_install() {
+ domenu usr/share/applications/onlyoffice-desktopeditors.desktop
+ for size in {16,24,32,48,64,128,256}; do
+ newicon -s "${size}" opt/onlyoffice/desktopeditors/asc-de-"${size}".png onlyoffice-desktopeditors.png
+ done
+
+ dobin usr/bin/desktopeditors usr/bin/onlyoffice-desktopeditors
+ doins -r opt
+ fperms +x /opt/onlyoffice/desktopeditors/{DesktopEditors,editors_helper,converter/x2t}
+}