summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-09-04 12:28:19 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-09-05 15:26:00 +0200
commit3bb8fd5009e3f7ea625ba3fca0d2aa0c4f9e6f55 (patch)
tree121b9127d62551a5ec22f09422808932ef08d6c6 /app-misc
parentapp-misc/gramps: drop 5.1.6-r3 (diff)
downloadgentoo-3bb8fd5009e3f7ea625ba3fca0d2aa0c4f9e6f55.tar.gz
gentoo-3bb8fd5009e3f7ea625ba3fca0d2aa0c4f9e6f55.tar.bz2
gentoo-3bb8fd5009e3f7ea625ba3fca0d2aa0c4f9e6f55.zip
app-misc/gramps: add 5.2.3
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gramps/Manifest1
-rw-r--r--app-misc/gramps/gramps-5.2.3.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/app-misc/gramps/Manifest b/app-misc/gramps/Manifest
index 21ee3a3cde1b..bd96f3bad8af 100644
--- a/app-misc/gramps/Manifest
+++ b/app-misc/gramps/Manifest
@@ -1 +1,2 @@
DIST gramps-5.2.2.tar.gz 21070723 BLAKE2B 8edf794e766663a1536cc50599a418ccb6e06ea832be14227aaa29336a1165f54c00cfb5fa7ed6657256b6660d3217ac4f4e2e62d41097d66808f0f4f554238c SHA512 4e2480081c16a61e9b0d4b0bbecccf4e6af6a40498d6994d8103ac37a7f3ce7993359fc0a9ee72cb06173ab82e17029e1a731bcf4af360cfc73e3c44c9800ef5
+DIST gramps-5.2.3.tar.gz 21081011 BLAKE2B 1ed8bc46e3c0d49b77194e52a060e5e3627871620f87bb7aca1b112972aecbd94a382cbc03ac07f8ef0424b4e47abbb4245ec4761fce5f5b019bdf41591530a1 SHA512 830af5c7276ff4e6c3a43ce37f1cd7bf345368885489701d17e4fe276f468890b267c5c72d7055e6043dc715e7a7f950e5a2084e31863d338c3487f29561ac75
diff --git a/app-misc/gramps/gramps-5.2.3.ebuild b/app-misc/gramps/gramps-5.2.3.ebuild
new file mode 100644
index 000000000000..391d5dc54184
--- /dev/null
+++ b/app-misc/gramps/gramps-5.2.3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 2001-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Community genealogy program aiming to be both intuitive and feature-complete"
+HOMEPAGE="https://gramps-project.org/"
+SRC_URI="
+ https://github.com/gramps-project/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="exif geo postscript +rcs +reports spell test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.12:3[cairo,${PYTHON_USEDEP}]
+ dev-python/pyicu[${PYTHON_USEDEP}]
+ exif? ( >=media-libs/gexiv2-0.5[${PYTHON_USEDEP},introspection] )
+ ')
+ gnome-base/librsvg:2
+ >x11-libs/gtk+-3.14.8:3[introspection]
+ x11-libs/pango[introspection]
+ x11-misc/xdg-utils
+ geo? ( >=sci-geosciences/osm-gps-map-1.1.0 )
+ spell? ( app-text/gtkspell:3[introspection] )
+ rcs? ( dev-vcs/rcs )
+ reports? ( media-gfx/graphviz[postscript?] )
+"
+BDEPEND="test? (
+ $(python_gen_cond_dep '
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ ')
+)"
+
+DISTUTILS_ARGS=(
+ --no-compress-manpages
+)
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Install documentation to the proper location. This can't be done
+ # easily with a patch because we substitute in the ${PF} variable,
+ # and that changes with every revision.
+ sed -i -e "s:share/doc/gramps:share/doc/${PF}:g" setup.py || die
+
+ default
+}
+
+python_test() {
+ # gramps.gen.utils.test.file_test.FileTest.test_mediapath expects existing ~/.gramps
+ # see https://gramps-project.org/bugs/view.php?id=13305
+ mkdir -p "${HOME}/.gramps" || die
+ # we need to populate test data to resources, they are not installed
+ ln -snf "${S}/data/tests" "${BUILD_DIR}/install/usr/share/gramps/tests" || die
+ # test_imp_sample_ged wrongly detects mimetype for OBJE without file in ${S}
+ rm -f data/tests/imp_sample.ged || die
+
+ local -x GRAMPS_RESOURCES="${BUILD_DIR}/install/usr/share" GDK_BACKEND=-
+ eunittest -p "*_test.py"
+
+ # we don't want to install this symlink
+ rm -f "${BUILD_DIR}/install/usr/share/gramps/tests" || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}